Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

How to solve internal software error (error 7) while compile to NI Crio FPGA

Hi there!

 

  When I try to compile my LabU FPGA code I got the error below. 

  I was able to compile the code before but with no reasons it stopped working (after a canceled compilation).

 

Please help.

 

 

 

The error message: 

 

An internal software error has occurred. Please contact National Instruments technical support at ni.com/support with the following information:

Error 7 occurred at an unidentified location

Possible reason(s):

LabVIEW:  File not found. The file might have been moved or deleted, or the file path might be incorrectly formatted for the operating system. For example, use \ as path separators on Windows, : on Mac OS, and / on Linux. Verify that the path is correct using the command prompt or file explorer.
=========================
NI-488:  Nonexistent GPIB interface.

0 Kudos
Message 1 of 10
(5,413 Views)

Hi,

 

Here is one thing you can try that might solve your problem. Try deleting (or renaming) the ClntTmp and SrvrTmp folders in your hard drive.

Those folders will live under NIFPGA86  (or similar, if using something different than LV 8.6).  If Windows doesn't allow you to rename/delete the folders, reboot the PC.

 

Hope that helps. 

 

JMota

Message 2 of 10
(5,408 Views)

I have been getting this error a lot!!!  I have been in contact with NI about the issue, but they never really gave me any real answers.  I have now updated to 8.6.1 to see if that would help get rid of this problem.  Didn't help!!!  The crazy thing is that I have gotten this error across 4 different computers now.  I thought it might be something in my project, but it seems to bomb on the example FPGA projects from NI as well.  Has anyone else had serious problems with this?!?!  I am out of ideas.

 

I always get the error at the 12% point during step 2 of the intermediate files build.

 

If someone here can help me, I will gladly post the email traffic I had going back-and-forth with NI Tech Support.

 

The crazy part is that I sent NI my entire project folder, they told me that they compiled the FPGA without any problem, so that helps me feel confident that it isn't anything particular about my project or code that is causing it to blow-up.

Message Edited by biographie on 03-09-2009 12:23 PM
0 Kudos
Message 3 of 10
(5,211 Views)

Can you check the versions of your LabVIEW, LabVIEW RT and LabVIEW FPGA in Measurement and Automation Explorer?

 

I have seen issues where LabVIEW 8.6 was upgraded to 8.6.1 but the Modules remained in version 8.6

 

Regards,

 

Juan Galindo
Applications Engineer
National Instruments
0 Kudos
Message 4 of 10
(5,159 Views)

Hello,

 

I am having the same problem, using the embedded eval kit.

 

I get error 7 and error 1 every time I try to compile a vi. Even the vi from the tutorial exercise 2.

 

error 7.JPGerror 1.JPG

 

I checked in MACs and found that the version of the FPGA module is indeed 8.6. This is what was installed by the DVD that came with the eval kit. I also renamed the two directories mentioned.

 

To no avail...

 

0 Kudos
Message 5 of 10
(4,874 Views)

Has anyone tried this solution?

http://digital.ni.com/public.nsf/allkb/CCEAE7847F41C36A86256D1F0070D224?OpenDocument

Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 6 of 10
(4,824 Views)

Yes, I tried the solution of 'My FPGA VI Compilation Fails With an Open File Error' renaming the tmp directories.

I still have the issue mentioned in the original post, stopping with a -1 'internal error', though I do not have the #7 file error, just the internal. Feels related to the installs, am scouring the 2009 SP1 with repairs to see if I can make it go away. I also had cancelled the first FPGA build (could be a cause), but am trying to figure this out on a new system/install.

0 Kudos
Message 7 of 10
(3,857 Views)

Hi LabviewFL

 

did you managed to compile your FPGA code? If not or you have more questions would you please open a new thread?

 

Thanks,

Barna D.

National Instruments

0 Kudos
Message 8 of 10
(3,747 Views)

Yes, my issue was solved by upgrading to NI-RIO 3.5.1

0 Kudos
Message 9 of 10
(3,741 Views)

We had and solve this problem.  For us, a DLL used by Xilinx (libBZ2.dll or similar) was overwritten by a different version by a different sw install (PowerArchiver, I think).  Xilinx apparently has it's own version of the library so when we removed the windows/system32/libBZ2.dll the problem went away.  

0 Kudos
Message 10 of 10
(2,937 Views)