Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

How can I fix "Inconsistent IP Settings" in NI MAX?

Solved!
Go to solution

Hi everyone, I am using LabVIEW 2012 SP1, my hardware is an NI 3110 Industrial Controller which connects to various Beckhoff EtherCAT terminals.

 

I am having a problem with "Inconsistent IP Settings" in NI Max when I try to connect to my RT target (NI-3110 Industrial Controller). I am able to connect to the target without problem, but whether it is via Static IP or DHCP I continue to get "Inconsistent IP Settings". I uploaded some screenshots to an imgur album you can view here. Here is a list of things I have tried (and various combinations):

 

1/ Flipped "IP Reset" switch on the Controller, reset it and set the PC ip to a Static IP on the same subnet.

 

2/ Flipped the "Safe Mode" switch to boot the target in Safe Mode and connect to it.

 

3/ Formatted the target and reset network adapters through MAX.

 

4/ DHCP configuration where target has it's own IP assigned to it automatically, and is visible on my University network.

 

To be clear, I am *not* having a problem connecting to my target, it is very easy to connect to it via DHCP and Static IP, however I cannot seem to get rid of Inconsistent IP Settings.

 

I have read numerous forum topics and knowledgebase articles that suggest this is usually a result of the IP of the target and the PC being on a different Subnet. However as far as I can tell this is absolutely *not* the case. The IP address of the target is 10.158.20.8, and the host PC is 10.158.20.x (it varies) and the Subnet Mask is 255.255.255.0, so the IP addresses *are* on the same Subnet. I even put it in one of those Subnet Calculators just to make absolutely sure. 

 

One thing that stands out for me is that when I have the Controller connected to the network with DHCP on and it acquires 10.158.20.8 automatically, it has a strange subnet mask (see the 4th image here), I assumed it would be 255.255.255.0 like when I do ipconfig in a Command Prompt. Could this be causing the Inconsistency? If so, can I change it? 

 

Also every time I reset the target through MAX (after changing from DHCP to Static IP, or vice versa) MAX does not connect to it again automatically, I have to delete the target and refresh MAX and it registers it again.

 

The final 2 screenshots in the imgur album (found here) are the video output of the controller (just connected a monitor via VGA cable with an adapter). The 5th image is what I *currently* see, and the final image is an old screenshot, of what it *should* look like. In the first boot screen image, the message "Error booting hard drive boot program" sticks out, does that indicate some kind of hardware malfunction? I don't remember seeing a message like that when I originally set up this system.

 

So in summary, I keep getting "Inconsistent IP Settings" - I have tried all of the usual suspects, all IPs are on the same Subnet etc, it seems like there is some *other* problem that is causing Inconsistent IP Settings that I cannot detect. Any help is greatly appreciated, since I have this error I cannot install any software to the target, which means I cannot instal NI Industrial Communications for EtherCAT, aka I cannot do anything until I fix this. Please let me know if there is any additional information I can provide as well.

 

All the Best,

 

P.S. I created a Technical Support Report in MAX and attached it in case it is useful for feedback!

0 Kudos
Message 1 of 24
(6,632 Views)

Hi,

 

Is the controller connected directly to your PC? So not through a complete network? Maybe it is best to start this way, connect it directly to your pc (in the past the controllers had to use a cross cable for this, I'm not susre if this is the case for yours), set your PC network card in the proper static range and make sure that the other network port of your target (the ethercat part) is on a different network range. Does this change anything?

If not can you try with another PC? 

 

 

Ps: there were no pictures attached to your post, I couldn't find it in the zip

Message 2 of 24
(6,470 Views)
Solution
Accepted by topic author cmorris89
07-07-2016 03:33 AM

Hey thanks for your reply. The pictures were in an imgur album linked in the post. I did indeed try everything to connect to the controller, I made sure my Network Card had the function to automatically detect crossover (apparently it is industry standard for Gigabit Ethernet cards). I even managed to try two Controllers, a colleague had a spare one, and ultimately the problem turned out to be a software incompatibility. I borrowed a laptop from the University department and installed the same software I have on my original laptop and tried to connect to the Controller and it worked fine, no Inconsistent IP Settings.

 

From there I could tell that the problem was related to the original laptop, since Inconsistent IP Settings did not appear on the borrowed Laptop. I actually ended up completely reinstalling LabVIEW on the original Laptop just in case it was somehow a corrupt install somewhere. I noticed however that a colleague had updated the NI System Configuration to 15.0. If I recall, there is typically backwards compatibility to 3 previous versions of LabVIEW, so version 15 with a LabVIEW 2012 SP1 works fine. However, during this fresh install of LabVIEW (before I updated to NI Sys Config 15) I checked the controller, and I connected to it fine, no error. Then I installed version 15 of the Sys Config and *then* got Inconsistent IP Settings. So the best I can figure is that this is some kind of bug in backwards compatibility between NI System Configuration 15 on a LabVIEW 2012 SP1 install. That, or it's related to the fact that the controller I am using is waaaay out of fashion and unsupported in some ways nowadays.

 

Thanks for your reply anyway, I forgot to get around to posting the solution I found here, so hopefully if anybody has this issue they can check their version compatibility and things like that!

Message 3 of 24
(6,468 Views)

Exactly same situation here,

I have an RT Target (Running LV RT 2014) that if seen from MAX 15.3.0f0 appears as "Inconsistent IP Settings" but if seen from MAX 14 works fine.
My big problem is that I need to upgrade the target to LVRT 2015 and I'm not able to do that because MAX 15 refuses to install any sw on an "inconsistent IP settings" target.

ps:ftp works fine.

 

0 Kudos
Message 4 of 24
(5,603 Views)

Have you tried just deleting the target from under Remote System? Then close NI-MAX and reopen again

 

 

 

0 Kudos
Message 5 of 24
(5,595 Views)
Solution
Accepted by topic author cmorris89
11-11-2016 02:09 PM

Also I dont know what version of software you are using but you might be running into this issue

 

http://www.ni.com/product-documentation/53420/en/

 

in which case downlaod and install this patch

 

http://www.ni.com/download/ni-system-configuration-16.0.1/6411/en/

Message 6 of 24
(5,585 Views)

of course yes, i've tried various network configuration: direct link, using an hub with fixed (192.168.x.x) or automatic ip address (169.254.x.x), using a switch with DHCP enabled... none of them worked with MAX 15

0 Kudos
Message 7 of 24
(5,579 Views)

Thank you Miro_T for the tip, because going back to LVRT 2014 is not an option I'll try to update to MAX 16 and see what happen.

0 Kudos
Message 8 of 24
(5,577 Views)

I hope that works put for you. Post again if it doesnt!

0 Kudos
Message 9 of 24
(5,571 Views)

The update of "NI System Configuration" to version 16.0.1 has fixed my issue!

I've searched a lot by googling and on NI site about this issue but without luck... until now.

 

Thank you very much Miro_T!!

Message 10 of 24
(5,561 Views)