Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

FPGA compile error

Highlighted

i am using the Crio 9074  I installed the new Labview 2009 on the PC and on the Crio. When i run the FPGA vi, it open the LABVIEW FPGA COMPILE SERVER 2009 Window and the SERVER STATUS shows COMPILING... the same time the COMPILATION STATUS WINDOW is open. After few seconds the server status on the compilation window shows IDLE.... And the Error Window appeared.

The error message windows are attached to the post, check it please.

I first reinstall all the Labview products on the PC (uninstall and install all of them), but the result was negative (same error message).

Today i repair the FPGA module only but without success. One thing i notice, the message says: MAKE SURE A COMPATIBLE VERSION OF XILINX TOOLS IS INSTALLED AT THE LOCATION SPECIFIED IN THE LABVIEW FPGA INSTALLER. I go to Compiler Server -> and click on Configure... button : i can only see the Root Build Directory with it right directory. But i cannot see the Compiler Path or/and the Compiler resources with their directories.

Here is my problem, can some one help?

0 Kudos
Message 11 of 23
(1,362 Views)
Highlighted

Ubuntu_B:

 

The error you're seeing can sometimes occur if a copy of perl58.dll is corrupted. It's located in your local user temp directory. If you delete it, it should be re-created upon the next compile attempt.

 

There are a few other possibilities, but the big ones should be covered in this KB. Let me know if that helps 🙂

Caleb Harris

National Instruments | Mechanical Engineer | http://www.ni.com/support
0 Kudos
Message 12 of 23
(1,347 Views)
Highlighted

hello

iam also having the same problem..

i tried to find perl58.dll file but in vain. can somebody tell me how to locate this file.

Also how to check HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\LabVIEW\9.0\AddOns\FPGA has CompilerPath set to C:\NIFGPA2009\Xilinx\ISE.

i doubt that this could solve my problem but i don,t know what is this location "HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\LabVIEW\9.0\AddOns\FPGA"

 


anybody can help??

0 Kudos
Message 13 of 23
(1,136 Views)
Highlighted

Hi:

 

In order to find perl58.dll, you'll need to search your user temp directory. Alternatively, you can simply search your entire hard drive. You can do this within Windows using the search function (on your keyboard, press "Windows + F." Alternatively, there may be a "Search" link in your start menu).

 

To check the path within "HKEY_LOCAL_MACHINE\SOFTWARE\National
Instruments\LabVIEW\9.0\AddOns\FPGA," you'll need to search your registry. To do this, you'll need a Windows tool called "regedit." If you're not familiar with looking through your system registry, you may need to consult with someone who is more comfortable with the process. Changing your registry can result in breaking your operating system if you modify the wrong thing.

 

To run regedit, go to the start menu and select "Run." Once the "Run" dialog is open, type in "regedit" (without the quotes) and click "Ok."

Caleb Harris

National Instruments | Mechanical Engineer | http://www.ni.com/support
0 Kudos
Message 14 of 23
(1,122 Views)
Highlighted

When trying to compile FPGA, I am getting the error:

 

Error starting compile step: Check compiler path setting in the Configure Server dialog. Make sure a compatible version of Xilinx software is installed in the specified location.

 

 

The KnowledgeBase link on the second reply seems to be exactly what I need to solve the problem (http://digital.ni.com/public.nsf/allkb/9596359AD44D18CD862570130080204C?OpenDocument) but I cannot seem to download the file as it just hangs in the download process. 

 

Would it be possible to verify that link is still active?

 

Thank you very much.

 

JJL.

0 Kudos
Message 15 of 23
(1,100 Views)
Highlighted

Hi JJL,

 

I was able to open the link that you were referring to as well as the VI associated with it with no problem.  Were you having trouble opening the link itself or download the example VI included?  The example VI is only for additional steps if configuring the Compiler Directory doesn't work properly.  In case you still can't open the link, here are the steps to check the compiler directories:

 

 

 

Why Do I Get a Compiler Path Error in LabVIEW FPGA?

Primary Software:
Primary Software Version: 2009
Primary Software Fixed Version: N/A
Secondary Software: N/A


Problem:
I have a very simple application that I am trying to compile using LabVIEW FPGA, but when I try to compile I get the error

#SERVER ERROR: Error starting compile: Check "Compiler Path" in compile server configuration. #

After receiving the error, I am not able to compile. How can I fix this?

Solution:
This error can occur for a variety of reasons:

The options for the LabVIEW FPGA Compile Server are not configured properly. This should not be a problem for standard installations.

Verify these options in the LabVIEW Compile Server Configuration dialog box:

In Windows, navigate to and select Start»Programs»National Instruments»LabVIEW X»LabVIEW FPGA Utilities»CompileServer, where X is the version of LabVIEW that you are using. From the LabVIEW Compile Server window click the Configure... button. This will open the Configure Server dialog box. Make sure that the different paths that show up in that window exist in your computer. By default, they are

  • Compiler Path C:\NIFPGAX\Xilinx
  • Compiler Resource C:\Program Files\National Instruments\LabVIEW X\RVI\resource
  • Root Build Directory C:\NIFPGAX\srvrTmp


where X corresponds to the LabVIEW FPGA Module version you are using.
If one of these directories doesn't exist in your hard drive, you will need to repair the installation of the LabVIEW FPGA Module.

 

 

Regards,
Austin S.

National Instruments
Academic Field Engineer
0 Kudos
Message 16 of 23
(1,081 Views)
Highlighted

Hi Austin,

 

I was able to download the vi, and I have set the paths correctly but I am still getting the: 

 

Error starting compile step: Check compiler path setting in the Configure Server dialog. Make sure a compatible version of Xilinx software is installed in the specified location.

I was compiling correctly just two weeks ago, and I haven't used LabVIEW since that time.   The compile seems to work on other computers so it might just be some setting on my system.  Would reinstalling everything resolve this issue?

 

Thanks.

0 Kudos
Message 17 of 23
(1,077 Views)
Highlighted

Hi niblog

      reinstalling everything would definitely fix this isssue as it did for me. 

 

      which version of labview you are using. if u have installed service pack for base development pack and left others in the previous version this might happen.

 

Regards 

Temin

0 Kudos
Message 18 of 23
(1,066 Views)
Highlighted

Hi

I have CompactRIO 9002, 1 NI cRIO-9201, 1 NI cRIO-9263, 1 NI cRIO-9401 and LabVIEW 8.0 plus FPGA and Real-Time modules installed. I am getting started with Real-Time projects and I tried to do the example that is shown in "LabVIEW FPGA and CompactRIO Getting Started Tutorial", only difference is I changed cRIO-9215 to cRIO-9201.

I have created the project as the tutorial, following all steps, but when I try to compile in the cRIO a error appears the same error as shown in this topic:

 

Error starting compile step: Check compiler path setting in the Configure Server dialog. Make sure a compatible version of Xilinx software is installed in the specified location.

----------------------

Compile report: Release 7.1.03i - Xilinx CORE Generator IP_H.16 Copyright (c) 1995-2005 Xilinx, Inc. All rights reserved. Regenerating IP...

the output directory. Output products for this core may be overwritten.

 

I have already reinstalled everything. I have formated the cRIO to try solve this problem, but the error continues.

Please, if someone managed to solve this problem, help me!

0 Kudos
Message 19 of 23
(831 Views)
Highlighted

Hello,

 

What cRIO chassis are you using to connect to the 9002 controller?

What version of Xilinx tools is installed?

 

You will then want to make sure the version of Xilinx Tools installed supports that FPGA. Also if you haven't done so already make sure to follow the steps layed on the KBs in the previous posts.

 

Regards,

Danny F

Danny Funk -- Group Manager -- LabVIEW R&D -- National Instruments
0 Kudos
Message 20 of 23
(801 Views)