Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

FPGA compile error

Highlighted
I was trying to compile FPGA vi and failed. It gave me message "Error starting compile step: Check compiler path setting in the Configure Server dialog. Make sure a compatible version of Xilinx software is installed in the specified location". I checked compiler path is C:\NIFPGA82 and root build directory is C:\NIFPGA82\srvrTmp. And there are bunch of .vhd files under C:\NIFPGA82\clntTmp\.
 
How should I configure the compiler path?
 
Thanks.
0 Kudos
Message 1 of 23
(5,343 Views)
Highlighted
According to this KnowledgeBase article, the compiler path should be set to C:\NIFPGA82\Xilinx.  Please give this a try and let me know how it works out.  If it still fails to compile, there might be a problem with a registry key.  In that case, go ahead and run the VI attached to this article.  Thanks, and good luck.
0 Kudos
Message 2 of 23
(5,291 Views)
Highlighted

Thanks for the raply, Meghan.

I reinstalled FPGA module and now there is C:\NIFPGA82\Xilinx directory. I couldn't see the Compiler Resource item on Configure Server dialog, but the directory does exist. After the reinstallation, I compiled the server and got error message, then I recompiled again, it seemed work this time, no error message. Then call open FPGA reference function in FPGA vi, the vi is broken because it says " the vi is not compiled".

Where should the bitfile be located? I can not find it.

Do you see anything not correct through the procedure I did?

Thank you.

0 Kudos
Message 3 of 23
(5,280 Views)
Highlighted

Your procedure seems to be correct. The bitfile should be located under X:\NIFPGA85\clntTmp, where X is the drive on which you installed LabVIEW and the FPGA Module. 

 

0 Kudos
Message 4 of 23
(5,198 Views)
Highlighted
I see whole bunch of .vhd files but no .lvbit file under C:\NIFPGA82\clntTmp. Also, I didn't see the compiler tell you how many percentage has been used for this FPGA vi at the end of compile. Does it look properly?
0 Kudos
Message 5 of 23
(5,192 Views)
Highlighted
Sorry about that, the bit file should actually be located the the C:\NIFPGA82\srvrTmp directory - not the client.  Also, you are looking for a .bit file, not a .lvbit.  Please let me know if you find it here.
0 Kudos
Message 6 of 23
(5,190 Views)
Highlighted
There is no .bit under C:\NIFPGA82\srvrTmp\ directory. Only a file called xflow.log under C:\NIFPGA82\srvrTmp\localhost\Revelation_FPGATarg~A7_Revelati~65_nlb0jayv~1D.
0 Kudos
Message 7 of 23
(5,183 Views)
Highlighted
Have you tried looking in the folder that contains your FPGA VI, and project?  There should have been a folder created called "FPGA Bitfiles", where the bitfile will reside. 
0 Kudos
Message 8 of 23
(4,937 Views)
Highlighted

Hi,

 

I got this error also. This happened after installing LV2009 (on top of 8.5.1) on the PC that I am running the compile server on. I've checked the paths as well as the registry setting for performance counters that was mentioned in another thread.

 

Any ideas of what can be causing this?

 

Rgds,

Rob
0 Kudos
Message 9 of 23
(2,890 Views)
Highlighted

I am not using LV2009 but I am guessing the FPGA module wasn't updated properly when you upgrade to LV2009. Try uninstall and reinstall the FPGA module.

 

And the compiled bit file should be located under \your project folder\FPGA Bitfile\*.lvbit

 

Good luck!

0 Kudos
Message 10 of 23
(2,864 Views)