Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

EtherCat bus or REM-11120 problem?

I have NI-9035 cRIO and Ethercat bus with five REM-11120 modules. The problem is that module in position #4 is not working properly. As you see in the attached picture (note turned off LEDs in 4th module), the module does not detect disconnected (nor connected) thermocouple. Data reading from the module gives no making sense data (-32764 or similar).


The weird aspect is that if I replace this module to another one or, exchange this module with the one from another slot/position, I get the same result. So, seem that REM module is OK or?


The modules are configured, deployed and scan engine is in active mode.


Any ideas what is wrong with positoin #4? Or how to proceed in finding what is faulty or misconfigured?

Download All
0 Kudos
Message 1 of 5

When trying to switch scan engine to active mode I get an error 0x8005442C sometimes. Still no clue.


Can anybody suggest the right direction for solution?


0 Kudos
Message 2 of 5

In short:


It seem that there is some kind of a basic hw (or sw?) limitation, so no more than four REM-11120 modules can work at a time on a single EtherCat rail. NI support is stuck with this issue for a several months now. Has anybody encountered this problem?


The things are getting worse now after EOL of old SCXI modules, now we cannot measure 96 temperature channels from old good SCXI-1102B


 a disaster for our research...

0 Kudos
Message 3 of 5

I doubt they are limited to 4 modules per coupler. But I honestly think you should look at beckhoff I/O. The EL series is very similar, and was around before NI create the REM modules.

0 Kudos
Message 4 of 5

Do you mean to change the whole measurement platform or only EtherCat temperature modules/coupler?



0 Kudos
Message 5 of 5