Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

EtherCAT Problems


I was trying to settle an EtherCAT connection with NI cRIO-9037 as the EtherCAT master and a third-party EtherCAT slave from Gantner Instruments (Q.Station 101 T), when i try to enter the active mode in the scan engine, it shows the error HEX: 0x8005442C, on the other hand if i try to manually switch the slave to safe operational state or even to bootstrap state, it shows another error (-2147138493 or in HEX: 0x80054443).

I am utilizing:

  1. LabVIEW 2016
  2. LabVIEW 2016 real time
  3. NI-Industrial communication for EtherCAT 18.5
  4. NI RIO 18.5
  5. NI scan engine 5.0

I haven't done a single block of code, i have updated both the Firmware of the cRIO and the slave in their respective softwares. The master perfectly detects the slave, so i do not think it could be the ESI File, however it won't go to the active mode of the scan engine. Could anyone lend me hand please?

0 Kudos
Message 1 of 6

Have you tried reformatting and reinstalling the software again?

0 Kudos
Message 2 of 6

Hi Nicolas_loupe,


Could you provide the Wireshark log and ESI file with me? I could help to resolve this problem when I get these files.



0 Kudos
Message 3 of 6


Did you solve this problem?
I have now the same thing with MAXPOS 50/5.

Hope you see this and can reply to me!
Thank you.

0 Kudos
Message 4 of 6

Anyone solved this problem?

0 Kudos
Message 5 of 6

In my case it was caused by the wrong address of the variable in the xml file.

I wrote the subindex in hexadecimal value while it was required in decimal value.

Check that the variables declared in the RxPDO and TxPDO of the file have the correct address.

0 Kudos
Message 6 of 6