Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Error Code 56 when trying to read from MyRio 1900

Hi everyone,

Moderately experienced with LabVIEW, somewhat green when it comes to data acquisition.

 

I inherited an instrument that runs on LabVIEW17. I also inherited the LabVIEW project that was designed to run data acquisition. I did NOT inherit the computer that was running everything. I've been spending a couple days trying to get the system to run on my computer (which also runs LV17 on windows 10), but I have hit a wall.

 

The instrument uses a myRIO - 1900 to turn some LED's on/off and collected data from pressure transducers, but unfortunately, I can't get data out of it. I've included a snippet of the code that is causing the problem. The program tries to read data from the myRIO using UDP protocol. The first action, opening the port, works fine. The second action, "UDP Read," causes Error 56, which is essentially a timeout error. 

 

nschweit302_0-1632780526919.png

 

My current theory is that the myRIO is not generating an output. A few things I know: I am able to ping it and get a response. Both devices are on the same subnet mask. There is no issue with my computer firewall, it still doesn't work even if the firewall is completely off. According to NI-MAX, it is connected (see below). I also (think I) have all the relevant software installed. 

 

I am unsure about the UDP port, I don't know why 61555 was chosen and if that is a problem. It could be the myRIO is on a different port, but I haven't figured out how to find that information. That being said, I doubt it is different since I didn't change it. I also found the NI help page about error 56 and UDP (https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019Lz2SAE&l=en-US), but none of these solutions worked... Anyone have any other ideas!?

 

nschweit302_1-1632780859490.png

 

 

 

0 Kudos
Message 1 of 2
(269 Views)
Hello, have you solved this problem?
0 Kudos
Message 2 of 2
(132 Views)