Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Error -63044 with 9018 and 9024

My hardware: cRIO9118, cRIO9024, 9853, Laptop Lenovo T530
Software: Labview 2012, MAX5.5

 

In MAX under 9024 in "Devices and Interfaces" there is a red spot with white cross inside besides "NI cRIO-9118 "RIO0"". The Status of 9118 is:

***********************************************************************************************************************************************************************

Error -63044 (kRIOStatusRioRpcServerMissing):
The RIO server could not be found on the specified remote device. Ensure that NI-RIO software is installed and that the RIO server is running and properly configured.

***********************************************************************************************************************************************************************

 

When I tried to start the RIO server in the "services", it gives me an error like this:

*************************************************************************************************
Windows could not start the NI-RIO Server service on local Computer.
 
Error 1075: The dependency service does not exist or has been marked for deletion.
*************************************************************************************************


In a new project, when I tried to "add Targets and Devices" using the option 

"Existing target or device" and "Discover an existing target(s) or device(s)", 

Labview will be dead. Then I added 9024 manually. I also need to add the Chassis 9118 

and the C Series Module manually as if try to discover them there will be an error 

"The RIO server could not be found on the specified remote device. Ensure that NI-RIO 

software is installed and that the RIO server is running and properly configured."

0 Kudos
Message 1 of 12
(5,195 Views)

So it appears that this error comes down to the NI-RIO Server service not being able to start which almost always points to the service itself being corrupted. At some point, some of the NI software must have gotten corrupted. There is a rather simple way we typically resolve errors like this. The following KnowledgeBase article addresses an issue very similar to this: 


-Why Do I Get Error 1075 when Trying to Start the National Instruments mDNS Responder Service? 
http://digital.ni.com/public.nsf/allkb/A05913DE561AB739862579F7005C4F81?OpenDocument 

I would recommend first trying to do a repair of the NI-RIO driver and see if this helps to resolve the error. If not, try repairing MAX as described in the linked article above. If you can fix the NI-RIO Server service error then it should be a great help in resolving the -63044 error. Hope that this helps! 

0 Kudos
Message 2 of 12
(5,176 Views)

Thanks for the help.

 

How to repair of the NI-RIO driver? 

 

I have done the repair for the MAX several time, it doesn't help. 

 

In the original installation I have MAX 5.3, the problem after I install MAX 5.5. Is that the problem? If it is, how can I go back to MAX 5.3?

 

 

0 Kudos
Message 3 of 12
(5,174 Views)

It will be best not to try to go back to MAX 5.3, becuase if you want to do that you would need to uninstall MAX and that would imply that you would need to uninstall almost all NI Software from the computer and that can be very time consuming.

 

To repair NI RIO you just need to follow the same steps that you see on the link but instead of looking for NI Measurement and Automation Explorer, you need to look for NI-RIO.

0 Kudos
Message 4 of 12
(5,172 Views)

There is "NI-RIO 12.0" and "NI-RIO 12.0 for Labview Real-Time", which one should I go and what is the diffrence between these two?

0 Kudos
Message 5 of 12
(5,170 Views)

You should repair both, one is the drivers for the devices and the other is the support for LabVIEW Real Time.

0 Kudos
Message 6 of 12
(5,162 Views)

I did NI-RIO repair twice, and MAX 5.5 also twice, no help. The I spent 2 days repair all the packages, still no help. Is MAX 5.5 conflict with my Labview 2012 32-bits?

0 Kudos
Message 7 of 12
(5,147 Views)

According to the System Configuration 5.5 documentation, there should not be any conflicts with LabVIEW 2012:

 

http://joule.ni.com/nidu/cds/view/p/id/4086/lang/en

 

 

0 Kudos
Message 8 of 12
(5,139 Views)

I am encountering the same problem now. may I ask have you solved it? if so, could you please to help? Thank you very much!

0 Kudos
Message 9 of 12
(4,733 Views)

Hello, Jeromelei

 

I have met this issue twice. Once it is because I install too many packages on 9024, which make the real time OS paralysed. The second time it is because of the broken of some library file on the computer. And this time I tortured with reinstall Labview, failed, then reinstall Windows 7 and labview again.

 

If it is not the first situation I mentioned, I recommend you talk with NI to see if there is some special issue on your application and then go back to reinstallation of Laview and even Windows.

 

Best Regards,

Tao Wang

0 Kudos
Message 10 of 12
(4,728 Views)