Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

DWarn: Internal error 2 occurred


I have an application on a NI-cRIO-9012 that can run continuously for weeks without problems and the suddenly stop. When I look in the error log in MAX I find the following message:


10/24/08 05:38:34.078 AM
source/server/RTEmbEditor.cpp(73) : DWarn: Internal error 2 occurred. VI "RR lib.lvlib:RR Server (Target)" was stopped at unknown " " at a call to "RR lib.lvlib:Size arrayFG"


RR lib.lvlib:RR Server (Target) is my top-vi. I have attached an image of the block diagram of RR lib.lvlib:Size arrayFG I don’t see how there can be any problems there. Any ideas of what it could be?


The drivers installed on the cRIO are NI-RIO 2.4.0, LabView Real-Time 8.5.1, NI-VISA 4.3, NI-VISA Server 4.3


LabView 8.5, FPGA Module 8.5 and Real-Time Module 8.5 were used to build the application.

0 Kudos
Message 1 of 5

I don't think that it is necessarily your "RR lib.lvlib:Size arrayFG" VI. The RT may have happened to be running that part of the code when it crashed, unless this is the same error you get everytime? I believe that dwarn error 2 is an out of memory error. Scroll further down your error log and look for the amount of memory left for RTOS. Post your error log if you like.

Message 2 of 5
Hi Sima and thanks for your reply.It is likely that it is an out of memory error as we do use a lot of the RIO’s memory in this application. I will have better look at the log the next time the error appears. It has been quit difficult to debug as it can go weeks between the error occurs.Where do you find a description of the dwarn errors? I tried to search the forum, but could not find anything.
Message Edited by Terje on 11-14-2008 07:39 AM
0 Kudos
Message 3 of 5

I don't think there is a description of the dwarn errors online. I've come across that error before when we were facing a memory leak due to networked string shared variables on the RT (a desktop ETS). That was fixed in LV 8.5.1. It would be nice to have more descriptions on the errors and the things that the error logs report.


Are you using build array anywhere? Are your arrays being initialized?

0 Kudos
Message 4 of 5



Did anyone found a solution for this?

I have the same problem here. First with LabVIEW 2010, now with LabVIEW 2010 SP1.


I'm attaching my PH_EXEC file.




0 Kudos
Message 5 of 5