Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQCard6024E noise and sampling rate

Highlighted
I used to use a desktop PC with NI-6024E board running LabVIEW to do my data acquisition. Now I setup a new platform using a Laptop with DAQCard-6024E. I have encountered two problems with the exactly same vi and the same data I used before. I am using LabVIEW 6i with a P3-600MHz, 128MB RAM and Windows2000.

1. When I specify a scan rate for the ?AI Start? vi in my DAQ vi. Any number below 600 Hz will stop the program running right the way and give me an error message as follow:
Error-10608 occurred at AI Buffer Read.
Possible reason:
NI-DAQ LV: no transfer is in progress for the specified resource.

2. The signal being read into the computer (if I used a scan rate higher than 600Hz) is much noisier than using the 6024E bo
ard with the desktop. The noise has a characteristic as a spark. It looks like that one data point in a random period is much higher or lower than the rest of data points.

Can somebody help me solve these problems?

Thanks in advance.
0 Kudos
Message 1 of 4
(2,228 Views)
Hello;

This is looking like a hardware problem of some sort with your DaqCard. There is no reason for the same VI to work with a desktop PC and doesn't work with a Laptop. At this point I would advise you to upgrade the version of the DAQ driver (NI-DAQ) to the last version we have available which is 6.9.1 and can be downloaded from our website, and give that I try.
Hope this helps.
Filipe
0 Kudos
Message 2 of 4
(2,228 Views)
Not sure about the problem 1. I have the oposite problem of not being able to acquire data at rates greater than 10kS/s on a very similar laptop.

As to problem 2, just as a stab in the dark, relative to your PCMCIA slot, where is the power supply input for the laptop located. During testing, we discovered that unplugging the laptop power supply greatly reduced the noise content in our sampled data. Try this and see if it makes any difference. If it does, let me know by replying.

Allan
0 Kudos
Message 3 of 4
(2,228 Views)
I have tried to unplug the power supply, seen little difference in noise. Thanks anyway.
For the first part, We have solved it by manually setting the "time-out" at the "AI-Start" vi.
ZD
0 Kudos
Message 4 of 4
(2,228 Views)