Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

CompactRIO Modules are not Connecting

Go to solution

I'm trying to set up a compactRIO but the modules aren't being detected in NI Distributed System Manager, even after hitting Refresh Modules in the Scan Engine. LabView is able to detect the modules but the code won't compile. Looking at the memory usage in the Distrubted System Manager it shows that there is no memory available and there is no memory allocated. I tried restarting the device, uninstalling and reinstalling the software but nothing has worked. Any ideas of what I could do to try and fix it?


Thank you!

Also this was the tutorial I was using to set it up

0 Kudos
Message 1 of 4

Hi Danielle,


Have you tried right clicking on the cRIO in your LabVIEW project and selecting deploy all? This should deploy all of the shared variables associated with your modules.


What errors are you seeing when you try to deploy your VIs?

0 Kudos
Message 2 of 4

It says deployment was successfull but the modules are still not showing in the distributed systems manager. 

0 Kudos
Message 3 of 4
Accepted by topic author daniellem

Got it working! I reformatted the compactRIO and reinstalled the software and that seemed to do the trick. Thanks for your help!

For anyone else who runs into this problem I found the following documentation to be a good reference:


I followed the steps in the section "Troubleshooting Steps for NI Scan Engine Deployment". 


Message 4 of 4