Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Cannot add cRIO 9045 to LabVIEW NXG project

Go to solution

I have a cRIO 9045 hooked up to my computer and everything worked fine with LV2020. Now I decided to try LV NXG 5 - and struggle the get the cRIO running.



Everything is showing up in NI MAX and the cRIO is configured to run under LV NXG. All necessary software is installed on the target (I assume) and connection works just fine.


Problem description

After initializing a new project in LV NXG (5.0.0), I go to the SystemDesigner to add new hardware. The cRIO is showing up in the list so I click the 'add' button. This fails with something like "can't reach target under given address". No further error message etc.


Attempts to solve this

- change dynamic IP of target to static IP (same result)

- followed the steps described here  (didn't help)

- (!) re-installed LabVIEW NXG, NXG RT, NXG FPGA, CompactRIO drivers (in that order). This was really a pain but did not help either.


Related question

Can't add cRIO-9053 to NXG 5.0 project 

-> the solution described there did not help me.



0 Kudos
Message 1 of 2
Accepted by topic author MrFuppes

Solved it, finally!


What worked for me was to format the disk of the cRIO and re-install all Software, see How to Restore LabVIEW RT Target to Factory Default Configuration 

0 Kudos
Message 2 of 2