Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Configure the Date and Time For CRIO-9075

Dears,

 

I Face a Problem Now with the CRIO-9075 , i tried to update the date and time for the CRIO-9075 but every time i change it it returned back to its default value,

 

so can you please tell me how can i solve it?

 

thanks

Ahmed

0 Kudos
Message 1 of 7
(6,084 Views)

Just a few quick questions to help narrow it down.

-What is the default value that the time is returning to?

-What version of MAX/System Configuration do you have installed on your system?

 

It very well could be the internal battery in the CompactRIO that is not working properly. This battery is used to power the CompactRIO's internal clock, even when the power is disconnected. Since updating the date and time requires the CompactRIO to restart, this very well could be the problem.

dK
0 Kudos
Message 2 of 7
(6,067 Views)

Dear Daniel,

 

thanks For your Reply,

 

the Default Value that the Time is Returning is (00:00:00) , and the date is (1/1/1970)

 

the Max Version is ( 5.4.0f0)

 

the LabView Version is 2011

 

For the CRIO , the Installed RIO is ( NI RIO 4.1  for 2012 Version)

 

By the way this CRIO is a New One ( manufatured by 3/2013 ), so is it possible to have a damaged Battery ?

 

Thanks

Ahmed

0 Kudos
Message 3 of 7
(6,031 Views)

The cRIO-9075 does not have a RTC, so it has no way of preserving the time between reboots.  If you want the time to be set you will need to use something like 1588 or SNTP to set the time everytime the system boots.

 

http://digital.ni.com/public.nsf/allkb/D6734E48D0705B9386257942005DEA30

0 Kudos
Message 4 of 7
(6,025 Views)

Hi all,

 

i've also the same problem.

But im not able to configure the SNTP Server because the is no internet connection.

I'm getting the time over RS232 and try to set the time with the VI:

../vi.lib/nisyscfg\Set Time.vi

from the RT-palette.

 

But when i deploy the application i get an error message that he is not able to use/save that "Set Time.vi"-VI on the cRIO9075.

 

I also tried an older VI witch i download from somewhere:

rt_set_time_sub_second.vi

 

But it doesn't work too.

 

It is possible that i'm not able to set the Time by hand. That i only could use an SNTP server?

 

 

thanks

Oliver

0 Kudos
Message 5 of 7
(5,875 Views)

In order to use Set Time.vi you will need to ensure that you have "NI System Configuration" (not to be confused with "NI System Configuration Remote Support") installed on the target.

0 Kudos
Message 6 of 7
(5,857 Views)

Hi,

 

thanks for your answer.

The problem was the different version of the "NI System Configuration" on the cRIO and on the PC.

 

Thanks for help...

Oliver

 

0 Kudos
Message 7 of 7
(5,848 Views)