Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Can ping cRIO but can't connect in MAX

Solved!
Go to solution
Highlighted

I have a 9066 cRIO set up on a local subnet. I believe all the software and drivers are correct. I have deployed my program and it works fine except... when I add some fiber optic converters into the mix. Here is my system:

 

PC --> ethernet cable --> ethernet switch --> ethernet cable --> cRIO  *** This works fine ***

PC --> ethernet cable --> fiber converter --> fiber cable --> ethernet switch(sfp) --> ethernet cable --> cRIO  *** can't connect in MAX ***

 

When I connect with ethernet cables all the way through, ping time is <1ms TTL is 64. When I add the fiber converter, I can still ping the cRIO but ping time goes to ~250ms and TTL goes to 247. Then MAX can't connect to the cRIO. Is my connection speed too slow for MAX or the cRIO to connect? 

 

My fiber converter, ethernet switch, and sfp module are all 1000MB/full duplex. It's only about a 10m run of fiber. I have tried multiple fiber cables. I have tried the sfp in multiple slots. My sfp and switch are both from Advantech so I assume they are compatible with each other. At this point I'm planning to just buy a fiber PCIe card for my PC but I figured I should check with the experts first.

 

Thanks

0 Kudos
Message 1 of 4
(1,911 Views)

Hi,

Using fiber cables will inherently add more conversion overhead to your connection. This could explain the longer connection time you are experiencing when pinging the cRIO. If I may ask, why would you like to use fiber cables? I would recommend going with your second option of getting a fiber PCIe card for your PC.

T. Le
Vision Product Support Engineer
National Instruments
0 Kudos
Message 2 of 4
(1,889 Views)

I will be using fiber optic communication as a safety precaution because my test panel will have high voltage in it. (>6kV) 

 

Thuyanhl, do you know if there is a hard communication timeout in MAX or RIO where it's just too slow and won't work?

0 Kudos
Message 3 of 4
(1,881 Views)
Solution
Accepted by topic author db28
09-01-2016 01:40 PM

Hi,

 

There is a timeout in NI-MAX. The default is 4000 ms. The reason why you are not able to detect the cRIO in NI-MAX might be because the packets are corrupted along the way. If you would like to verify this, you can always monitor the packets with WireShark with the two different set ups. This way you can see if the packets are being set correctly or not. 

 

I hope this helps!

 

T. Le
Vision Product Support Engineer
National Instruments
0 Kudos
Message 4 of 4
(1,865 Views)