Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Application stops to work after half a day or a day of work

I have some project for cRIO-9072 control. It was designed as closed loop system to keep the vibrations of the shaker constant by measuring acceleration by NI9233 and adjusting amplitude of signal fed to shaker amplifier from NI9263.

To monitor and change setiings of this system there is a remote PC in a control room(about 40meters away).

When we first tried to start tis system in a plant using Cat5 or Cat6  ethernet cables it did not work at all as it looks like there is a lot of noise around. Whatever cables where used (shileded, double shielded etc) they did not work. After that optical cable was installed and some adaptor from optical to wired Ethernet. After that it started to work OK but....

On the same place we have some Vision device (Gig Ethernet camera that measures something) the measurement from this camera are done on the same PC used for RealTime interface. We had obviously to install same optical fiber cable for this camera and adaptors Wired Ethernet to Optical Ethernet. We are using 2 different Ethernet adaptors for Optical system and Real Time system. In general ssystem works but it appears that Optical System does not have very good connection, so picture sometime is distorted. You can take a look on attached screenshot(on a right there is an Ethernet adaptor statistics for the camera network card). As you can see there is a lot of errors. We will try to investigate where this errors are comeing from but for some time we could work withsome losses from Optical device.

The thing that bothers me that the program that is used as an interface between PC and Real-Time module stoppes to work approximately every half a day. The real time system still continues to wor. MAX shows that device is connected and running, but I have to reboot RealTime device from MAX and restart my interface program on PC. After that it works OK for some time.

I have included screenshot of error. As you can see there are some errors on it. Some of them are connected with NI.

One of the questions could Vision application connection error interfere with RealTime appplication?

What are the thoughts about avoiding theproblem of RealTime application.

Any comments are welcome.

Sorry for such long explanation....

0 Kudos
Message 1 of 2
(2,226 Views)

Hi Sergey,

 

I am sorry for the delayed response as I have been out of the office for a few days, in order to provide you with a solution to your problem we are going to need a lot more information. Could you clarify what exactly is happening to the cRIO to prompt you to reset it? Is the cRIO still functioning, at what point are you observing the "nipalu" errors?

 

Also could you reply with a diagram of exactly how your system is setup including what you are measuring and all connections (e.g. ethernet-optical ethernet). Manufacturers and part numbers would be useful. Also what software are you using?

 

 Many thanks,

Message Edited by Ben L on 12-16-2008 06:24 AM
Ben L
Field Engineer
National Instruments
0 Kudos
Message 2 of 2
(2,128 Views)