RTI DDS Toolkit for LabVIEW Support

cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to load shared library rtilvdds.dll

Solved!
Go to solution

From the RTI DDS Toolkit - CRIO example, I am trying to deploy the RTI Connect DDS Write Double vi to a cDAQ with Linux RT and am getting the following error:

LVDDS_library.lvlib:Release Writer.vi loaded with errors on the target and was closed.
LabVIEW: (Hex 0x436) Failed to load shared library rtilvdds.dll:LVDDS_WriterNode_dispose:C . Ensure that the library is present on the RT target. Use either MAX to install NI software or FTP to transfer custom libraries to the RT target.

 

I thought dll's were only for windows targets, any ideas?

 

0 Kudos
Message 1 of 3
(1,290 Views)
Solution
Accepted by topic author viScience

In order to use DDS on targets, you need to first install DDS on them through MAX. 

For cRIOs this is quite straightforward, but for a cDAQ it will likely require a modification to the cdf file to allow installation on the target. This will be something similar to the process described here

As to why the error message is that, I'd guess that maybe they reuse the same error message for windows and other targets. 

Message 2 of 3
(1,273 Views)

Yup you are correct.  I modified the .cdf file to include cDAQ and that mostly solved the problem.  Additionally I think the .cdf file was named incorrectly as rtivdds-linux-x64intel.cdf in the installation.  I changed it to rtivdds-linux-x64.cdf

 

 

0 Kudos
Message 3 of 3
(1,267 Views)