RF Measurement Devices

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-VNA 17.5 & 18.0 Acquisiton and Softpanel stop working after one month

Solved!
Go to solution

We recently updated one of our PXI applications to LabVIEW 2018 SP1.  Everything initially worked, but the VNA stopped responding one month later.  The VNA Soft Front Panel has an application error when it is opened, and LabVIEW acquisitions (including the provided examples) timeout during "niVNA Wait For Sweep Done.vi".  The Windows Event Viewer was able to show more of the error which stated that the NMath license had expired and linked to this page.  Installing NI-VNA 18.0 on another PXI system initially works, but will also expire after 30 days.

 

I have tried reinstalling all versions of NI-VNA from 15.0 to 18.0 and the only versions with this issue are 17.5 and 18.0.  I have also tried forcing the installation (setup.exe /reinstall) and resetting the NI MAX configuration database.  The PXI systems have all Windows updates installed including Microsoft KB3033929 as referenced in the NI-VNA readme.  

 

The only ways we found to temporarily work around this issue are to set the BIOS clock back within the 30-day evaluation of NMath or to install NI-VNA 17.0 or older.

 

For reference, we are using PXIe-8133 and PXIe-8135 controllers with Windows 7 Service Pack 1 and PXIe-5632 VNAs.

 

Did I miss a requirement or some troubleshooting step?

Message 1 of 10
(420 Views)

Hi, CMaddux

 

It seems like a bug in VNA driver 17.5 or 18.0 as you said.

The only way to resolve this problem just installs NI-VNA 17.0 or older.

 

I would like to know the reason you should use 18.0 version.

 

Thanks,

 

 

0 Kudos
Message 2 of 10
(356 Views)

We have already validated the LabVIEW 2018 version over hundreds of man-hours and have continued development in LV2018 this past month.  This project rarely gets upgraded because of the validation required and was several versions behind our other projects which limited our code reuse.  If we are to be stuck in a version for another 3-5 years, we want it to be on the newest LabVIEW service pack version currently available.

Message 3 of 10
(343 Views)
Solution
Accepted by CMaddux

Hey there,

 

Thanks for posting up such detailed troubleshooting steps and problem description! 

 

This is a known issue and is currently being addressed through CAR 701164. 

 

We have a workaround for you:

 

set environment variable

 

Have a great weekend!

RF R&D
National Instruments
0 Kudos
Message 4 of 10
(319 Views)

Thanks!  After adding the fix, the VNA Soft Front Panel and LabVIEW Acquisitions work again.

Message 5 of 10
(308 Views)

I'm glad this worked! I'm going to remove the key from this page as this should be fixed soon. For anyone else that runs into this issue please contact NI Support and reference the CAR above. 

RF R&D
National Instruments
0 Kudos
Message 6 of 10
(279 Views)

Hello NI

 

I am having the same issue. I am using NI-VNA 17.5 and the softpanel has stopped working with the error attached.

One of the messages in this thread suggested a change to the environment variable settings.

 

If NI could provide more detailed instructions on that, it would help.

 

Thanks,

0 Kudos
Message 7 of 10
(209 Views)

Hello rv55,

 

Sorry to hear you're encountering this issue as well. It will be permanently fixed soon! However, we do have a workaround. Please contact NI Support, reference CAR 701164, and tell them to reach out to RF PSE. The support engineer will be able to access this CAR and work with me to provide you the workaround. We're not posting the workaround publicly so I apologize in advance for the inconvenience! 

 

 

RF R&D
National Instruments
0 Kudos
Message 8 of 10
(182 Views)

Hello,

 

We already contacted NI support last Friday via NI's online system and have even cited CAR 701164 and the link to the bulletin site it was originally posted.

 

NI has issues us Reference#7777302 but has not provided a fix yet.

 

We just need to do a couple of quick basic S-parameter measurements for a deadline this Friday 12 July.  It would be helpful if NI could fix this issue at the earliest. Please email me directly.

 

Thanks

0 Kudos
Message 9 of 10
(173 Views)
Highlighted

Thanks for providing the reference #. I just looked it up and it shows that the engineer you are working with on the reference emailed you the workaround yesterday. If you don't see their response in your email feel free to call in on the service request to get access to the workaround right away. I also sent the support engineer an email directly to reach out to via phone. Sorry again for the inconvenience here. Keep me updated. 

RF R&D
National Instruments
0 Kudos
Message 10 of 10
(169 Views)