PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

missing NIHWDBDD.dll on bootup

Hi,

 

I have 2 RMC-8354 PXI controllers, one which has current code / configuration (controller 1) on it and the other which doesn't (controller 2). I created an image of controller 1 using the NI vi's and then deployed it onto controller 2. When the image has been deployed, the controller reboots twice, the second time it pops up saying that it cannot locate NIHWDBDD.dll. Subsequent reboots give the same error message.

 

Why isn't this file included in the image? I've tried redeploying the image, but the file is still missing.

 

I'm using LV 2013 Sp1 (32 bit) - I've attached the code I'm using to build and deploy the images in case I'm the problem!

 

Al

0 Kudos
Message 1 of 3
(2,843 Views)

Hi Al,

 

Which operating system are you deploying?

One likely cause is that the file is included in the image, however your antivirus software is blocking the folder location. If this is the issue, adding \Program Files\National Instruments\ to your antivirus software's exceptions list will solve it.

0 Kudos
Message 2 of 3
(2,823 Views)

Sorry, I should have included that in the initial post! Its the Real time operating system I'm deploying. The windows PC thats running the create / deploy image VI is windows 7.

 

I'll try adding that folder to the exception list and see how I get on.

 

Al

0 Kudos
Message 3 of 3
(2,821 Views)