PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

installing LabVIEW RT 9.0

I'm trying to upgrade to LabVIEW RT 9.0 from 8.6.1.  I have 2 PXI Systems.  One of them is a dual-boot but is set to boot into LabVIEW RT not Windows.

 

First I upgraded a PC [Windows XP SP1] with LabVIEW 2009 and all necessary components so it could be a host to a LabVIEW RT PXI System.  Then I used MAX to upgrade both PXI Systems to LabVIEW RT 9.0.  The dual-boot completed the upgrade with no problem.  The other PXI System now if failed to boot.  After it attempts to start the LabVIEW RT Boot Loader I get the errors;

 

error reading c:\ph_exec_smp.exe

error booting c:\ph_exec_smp.exe

 

I cannot boot it into Safe Mode or ping it from the host PC.  MAX shows it as disconnected and I cannot add or remove software.

 

Next I upgraded another PC [Windows XP SP2] with LabVIEW 2009 and all necessary components so it could be a host to a LabVIEW RT PXI System.  In the process of upgrading I got BSODs with a BAD_POOL_CALLER errors.  I found this strange since I was using the same portable external DVD player to to read the NI installer disc.  I rebooted and tried re-installing several times.  Sometimes I would get LabVIEW errors but always ended up with a BSOD.  I even used the Windows utility to un-install any existing LabVIEW 2009 components and used a different DVD player.  Eventually when I got a LabVIEW error regarding installing LabVIEW RT, I aborted installing that component and LabVIEW 2009 was successfully installed. 

 

I have since installed LabVIEW 2009 on another PC [Windows XP SP2] and on the dual-boot PXI System when I booted it into Windows.

 

How do I recover my non-bootable PXI System?  How do I install the necessary RT components on my 2nd host PC?  Is this a problem with my installation DVD or with Windows?

0 Kudos
Message 1 of 3
(2,916 Views)

Faustina,

 

Is the controller that you are getting this error from dual boot or is it a standard real time controller?  Have you tried formatting this controller though MAX?  If you reinstall 8.6.1 to this controller does it work again or does it give the same error? Also, what controller are you using?

Justin Parker
National Instruments
Product Support Engineer
0 Kudos
Message 2 of 3
(2,893 Views)
problem resolved - thank you
0 Kudos
Message 3 of 3
(2,888 Views)