PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading PXI real-time OS from Windows XP; what needs to be downloaded?

Hello,
 
We purchased LabView 7.0 with real-time for our Windows XP host and PXI-8176 controller in fall 2003.
 
I've been running my application successfully since then. Yesterday I upgraded to LabView 7.1 using the updates distributed in Aug 2005.
 
On the Windows XP host, I didn't seem to have any problems with the upgrade. I then used MAX to create a new boot floppy for the PXI computer, and tried to use MAX to download the upgrades to the PXI that runs the real-time OS.
 
By default, MAX was set to automatically select the software to download. To my surprise, it recommended downloading nothing, even though the PXI had real-time 7.0 on it, and real-time 7.1 was now available the Windows XP host. I then selected download all, which included quite a few things that I don't know what they do!
 
The installation appeared to proceed correctly, but now I"m having trouble downloading my old LabView application to the PXI machine. It stalls part-way through downloading my VIs, and the PXI needs to be rebooted.
 
Can someone tell me the minimum of what packages need to be installed on the PXI to run LabView real-time programs?
 
Thank you in advance,
Frenk
0 Kudos
Message 1 of 3
(2,315 Views)
Hi There:

One thing I can recommend is to do a mass compile on your vi to make it a 7.1 vi instead of a 7.0 vi. Next, if you expand the software tab for your particular controller, does it show to have LabVIEW RT 7.1 or LabVIEW RT 7.0. The version of the LabVIEW on your host and on your RT target should be the same. Else you will not be able to target it.

Could you also list the exact error that you are getting?

Thanks,

Jaideep
0 Kudos
Message 2 of 3
(2,308 Views)

Hello,

Thanks for your response.

I wasn't getting an error other than "connection to PXI lost", and it was lost forever, even to MAX. That's why I had to reboot it everytime!

 

I went ahead and removed all the other software on the PXI, other than LabView Real-time 7.1 and the Traditional NI-DAQ 7.4.0. Now it works fine!   🙂

 

Thanks again,

Frenk

0 Kudos
Message 3 of 3
(2,304 Views)