PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Software intalled, indentified MAX, cannot find PXI-7813R in the project

Solved!
Go to solution

Hi,

 

I'm having a small problem with adding the FPGA target.

I think the software is installed, versions are matched, and the connection has no problem, MAX even shows nice detection of the devices. But I just cannot find the FPGA target in the project tree. Even though I look for just new target (not automatic searching), I still don't see PXI-7813R but I do see some other PXI R series.

Is there something I can do at this moment? Thanks in advance,

 

loorex07

0 Kudos
Message 1 of 11
(3,111 Views)

Do you install following device driver?

NI R Series Multifunction RIO 19.0 - NI R Series Multifunction RIO Device Drivers May 2019

 

Emboar_0-1574995770677.png

Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 2 of 11
(3,042 Views)

Hi Emboar, 

 

Yes of course, but it still didn't show up after this so I installed the latest one again (19.1) but somehow it is still not there. Manual clearly says it supports PXI-7813R, but as you see in the attached screenshot, it only shows PCI-7813R.

 

Best,

loorex07

 

0 Kudos
Message 3 of 11
(3,040 Views)

To be honest, I have a confusion. If support for PXIe-7813R is end, PCI/PXI-7813R also must be I believe.

In fact that you are seeing the problem so, I guess 19.1 doesn't provide device support for PCI/PXI/PXIe-7813R.

 

I want a reply from NI employee.

Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 4 of 11
(3,038 Views)

In the past, I had a similar problem. NI-IMAQ driver said it supported PCI-1408 but as the result, it didn't.

Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 5 of 11
(3,037 Views)

Yeah, that is also my first guess. I still need someone can tell about this. Thanks though, happy thanksgiving!

 

loorex07

0 Kudos
Message 6 of 11
(3,029 Views)
Solution
Accepted by topic author loorex07

Hi loorex07,

 

Support ends for PXI-7813R for LabVIEW 2019, NI R Series Multifunction RIO 19.0.

Support continues for PCI-7813R.

 

In this document Software Support for CompactRIO, CompactDAQ, Single-Board RIO, R Series, and EtherCAT you can find the information about compatible version of LabVIEW and Drivers for both - PCI and PXI version of the module.

The Readme is truly confusing, let me report it internally in order to clarify it for others who may come into the same situation.

 

Thanks for noticing and bringing it up to our forums.

 

Best,

 

Patrik
CTA, CLA
Helping (sharing) is caring!

If the post was helpful - Kudo it.
If the post answered your question - Mark it as Solution.
Message 7 of 11
(2,962 Views)

I feel it is truly nonsense that Labview 2019 does not support PXI-7813R. Regarding the link that you sent, am I thinking correctly? This was helpful for solving my question but it is frustrating that I cannot utilize FPGA now. Thanks, though!

0 Kudos
Message 8 of 11
(2,913 Views)

Hello All,

 

can someone please tell me what I could be doing wrong in setting up my system.

 

I have NI PXIe Chassis which is using another vendors Controller running Windows 10 and I can see the 2 NI-HW (NI PXI 7813R) connected on this chassis (left side of Screenshot below) in the NI Max installed directly on the controller.

 

Then I have a windows Standalone PC running also windows 10 and a network cable connecting the external vendors controller to the Windows standalone PC. In the Max installed on the standalone PC, I cant see the NI PXI 7813R devices in Max (Right side of Screenshot below).

 

Am I missing something ?

The controller and Windows PC have IP addresses as 10.2.5.55  and 10.2.5.56 respectively (as example) and same Subnet 255.255.0.0. 

 

Thanks all for your assistance.

 

iWin_0-1661117499398.png

 

0 Kudos
Message 9 of 11
(1,567 Views)

I think you cannot access the PXI RIO card over ethernet (not the RT one, but regular), it has to be locally connected to the windows system you're using.

Santhosh
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions

Only two ways to appreciate someone who spent their free time to reply/answer your question - give them Kudos or mark their reply as the answer/solution.

Finding it hard to source NI hardware? Try NI Trading Post
0 Kudos
Message 10 of 11
(1,557 Views)