PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

RFmxInstr Configure External Attenuation Table

If I set an attenuation table for port if0, my specAn, should I see the noise+CW compensated?  Or does the attenuation table correct on the SigGen setup only? In other words, when I fetch a spectrum I don't expect the entire table compensation included.  If I take a peak measurement then I expect the attenuation table to self correct.  This is what I'm seeing when I use this function.

 

I use the VI, Configure External Attenuation Table.vi, to set and enable the rf path loss of cables, adapter etc.  There are two ports if0 and if1.  I set my SpecAn to if0, SigGen to if1, I only see correction for SpecAn when I set the attenuation table to port if1. (Is this expected?).  I can use port::all but rather know how this should function.

 

 

 

 

0 Kudos
Message 1 of 5
(486 Views)

OK, I did further checks.  Using RFmx SpecAn, the External Attenuation Table only works when the port is set to if1. Can someone confirm or disprove this?  If this is correct, why?  If not correct, explain.

 

Port if0, does not execute an attenuation correction.  I've toggled ports for my SigGen and SpecAn setup, either way Table corrections only work when the SpecAn is set to port if1.

0 Kudos
Message 2 of 5
(459 Views)

richjoh_0-1640284845104.png

 

It appears to be a problem with port::if0 correction table not loading.  If I include a calplane name, i.e. "calplane::plane0/port::if0", right out of the example, the correction table still does not load.  If I use port if1 the correction table loads OK.  I'm using PXIe-5830. 

 

I reverted to using port::all as a work-around for port if0 correction table to load. 

 

Is this a bug in the VI?  Please confirm.

 

0 Kudos
Message 3 of 5
(405 Views)

@richjoh indeed this feels like this might be an issue, but we'd like to have it brought into our support system. Would you be so kind as to create a support request and we'll get this routed to the right team and person if it's still not resolved.

 

0 Kudos
Message 4 of 5
(321 Views)

Do you have a link for creating a support request?

0 Kudos
Message 5 of 5
(313 Views)