PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

PXIe-8245 Ethernet Card not detected by NI MAX 2016

Solved!
Go to solution

I physically installed PXIe-8245 card on our PXIe-1065 chassis. We use pharlap real-time OS on our target machine. I can able to see the new ethernet ports in NI MAX Network Settings page. But I dont see the card PXIe-8245 under Remote Systems -> Devices and Interfaces. Does Pharlap OS support PXIe-8245 card? 

0 Kudos
Message 1 of 8
(757 Views)

PXI Ethernet Interface Module Does Not Show Up Under Devices and Interfaces

On a Real-Time OS, the ports of the ethernet interface module appear in the Network Settings tab in MAX. If you are missing ethernet adapters, then the adapter is using a different chipset. By default, most chipset drivers are not installed on the Pharlap RT PXI controller. 

0 Kudos
Message 2 of 8
(727 Views)

Hello  ZYOng,

Thank you for your response. I do see 4 additional ethernet adapter under Network Setting (picture attached Network Setting.PNG) But I was also expecting it to appear under the chassis where the ethernet card is installed (picture attached Cards under chassis.PNG). If I understood you correctly, it only appears under Network Settings. Is it right? 

 

Also, is there a custom device which I can use to send data through these ethernet ports in real-time? Thank you.

Download All
0 Kudos
Message 3 of 8
(716 Views)
Solution
Accepted by topic author NickPil

If I understood you correctly, it only appears under Network Settings. Is it right? 

That's right. Just treat the Ethernet ports from 8245 like any regular Eth ports.

 

is there a custom device which I can use to send data through these ethernet ports in real-time?

I assume you are referring to the VeriStand Custom Device. Depending on what kind of network communication you want to do, you can start from VeriStand Open Source Add-Ons. E.g If you want to do UDP communication between another target and VeriStand engine, use NIVeriStandAdd-Ons/UDP-Data-Link-Custom-Device

 

Message 4 of 8
(708 Views)

ZYOng,

Thank you very much, this custom device would work for us. 

 

One more issue, I am unable to Enable (in NI MAX Network Settings) ethernet adapter eth0 if it is not selected as primary. Is it expected? Is there a way we can force particular port as eth0? Default, one port from PXIe-8245 is assigned as eth0 in the Network Settings and default RT ethernet port assigned as eth4 in the Network Settings

0 Kudos
Message 5 of 8
(637 Views)

@NickPil wrote:

Is there a way we can force particular port as eth0? Default, one port from PXIe-8245 is assigned as eth0 in the Network Settings and default RT ethernet port assigned as eth4 in the Network Settings


To my knowledge, no. I believe that NI R&D has only validated Eth0 to be the primary port for the host PC.

0 Kudos
Message 6 of 8
(623 Views)

Thank you, Eth0 is assigned randomly? Is this mean I have to always set Eth0 as primary and connect the host computer to this port? Thanks again, your support is really helpful.

0 Kudos
Message 7 of 8
(602 Views)

Eth0 is always assigned to the first Ethernet port of the controller.

0 Kudos
Message 8 of 8
(582 Views)