Showing results for 
Search instead for 
Did you mean: 

PXIe-8133 Windows 7 to Windows 10 upgrade: things fell apart, am I an idiot?

Was I an idiot for trying to upgrade from Windows 7 to Windows 10?


System: PXIe-8133 Controller in PXIe-1062Q Chassis... Keeping this simple with just a PXI-6514 Industrial IO plugin.


Was running Windows 7 and things were good. Upgraded to Windows 10 and things fell apart. NI MAX shows errors and does not see any of the plug-ins.


Ran Ni Package Manager and tried to "repair", with unit plugged into the internet, things chugged along for an hour and then she asked me to


"Select Distribution


National Instruments System Driver Set - May 2012".


I looked though the old CD's and found one labeled "NI PXI Platform Services for PXI chassis and controllers April 2012" with the nidist.id file on it. However selecting that sends me to a "Warning this is not a valid distribution location" error.


Question: was the Windows 7 to 10 move a bad idea? Or do I have the wrong "distribution disc"? Or am i just being stupid and missing something else?


Thank you for any help!


0 Kudos
Message 1 of 4

Morning update....


I downloaded the latest version of the BIOS for PXIe-8133, 1.2.4f0. Decided to enable the 64-bit handling of PCI bus in BIOS (no clue if that would help or is even related to my problem).


Tried the NI Package Manager “repair” again and this time it completed successfully!


Back to Ni MAX. Loads with no errors this time. Looking at “Devices and Interfaces” it shows the PXI0::1::BACKPLANE but right-click and select Open VISA Test Panel I get an error:


Error opening resource:



VISA: (Hex 0xBFF0011) Insufficient location information or the device or resource is not present in the system


Seems like some progress is being made but still fighting this... thank you for any info!



0 Kudos
Message 2 of 4

Another update.... after more software updates and “installation repair” sessions, she works! I can see devices and get measurements! Yay!




0 Kudos
Message 3 of 4

What process did you use to update the 8133? I need to update from 7 to 10.

0 Kudos
Message 4 of 4