From 12:00 AM CDT Sunday, October 17 - 11:30 AM CDT Sunday, October 17, will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.


Showing results for 
Search instead for 
Did you mean: 

PXIe-8130 and Labview 2015

I have a PXIe-8130 that I have been trying to get working again with Labview RT 2015 and it's not going well.  For everything I've tried so far, I am mostly only able to get it to say "Software reboot due to system error.  System State: safe mode".  


It's been sitting in storage for several months and I had Labview 2011 and previously Labview 2009 installed on.  I just replaced the CMOS battery because it was dead, and setup the system clock, and that solved the boot loops that had been happening.


I reformatted the hard drive using MAX, then used MAX to install the Labview RT 2015.  This succeeded, and I was able to run a simple VI.  But my application needs to run the PXIe-5122 digitizer and a serial port, so i need to install NI SCOPE and NI SERIAL.  When I then install these components and the prerequisites, the system then has the safe mode error and I am unable to run my VI.  I tried uninstalling those components, but it still boots into safe mode with the system error.


Can I get a hand with debugging what might be going wrong? 





0 Kudos
Message 1 of 4

Hi gregoryng,


That definitely sounds strange; What versions of NI Scope and Serial are you installing? What media did you use to install it to your host PC that you're installing from in MAX (assuming you're using this method)? Does the error still occur if you reinstall the drivers on your host (preferably from a fresh NI website download) and then use that to install on your target?

0 Kudos
Message 2 of 4

Hi Danni,


Since I'm with the University of Texas, we have an internal web site where we download installers, but I think that it just gets them from your web site. I was running somewhere around 15.0, 15.1, or 15.5 drivers. I think I updated previously some time in July.

In any case I updated my drivers to 16.0 through the NI Update Service, and tried again. I kept Labview RT 15.0.1.  And now it seems to work.  I hope that solves the problem...


Right now I'm only using the NI Scope driver but I'll be using others once I write in the other code, so hopefully they are equally successful.


0 Kudos
Message 3 of 4

Hi Gregory,


That's great! It sounds like there may have been a mismatch between your host and RT drivre versions, or it's possible that something wen wrong with your previous installation. It seems like a clean installation should work well moving forward!

0 Kudos
Message 4 of 4