PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

PXIe-5122 triggering problem

I have some problem in triggering the signal in my scope. I use PXIe-512214-bit 100MS/s Digitizer. What I did is I route Board Clock to RTSI0 and then in niScope Configure Triger Digital.vi, I use RTSI0 as the trigger source. But it always reported error "Source terminal to be routed could not be found on the device"and Destination Terminal is: PXI_Trig0. When I route RTSI clock to RTSI0, program runs, but the scope does not show any signal. What should I do now? Do you have any suggestions? Thank you very much:)

 

 

0 Kudos
Message 1 of 4
(3,080 Views)

Hi Olyaime,

 

Can you expand on what you are trying to do? What are you using to generate the clock that you are exporting to the PXI trigger line? Are you trying to synchronize multiple devices or are you only using the PXIe-5122?

Tunde S.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 4
(3,067 Views)

Hi, Tunde

 

Thanks for your reply. I am only using PXIe-5122 for Impedance Analyzer Software. Right now the scope has some problem in getting the signal. It always shows "Insufficient Signal Level on Reference Signal Increase: FGEN Amplitude". What I did is to route Board clock to RSTI0 using niFgen Route Signal Out.vi and then in niScope Configure Trigger Digital.vi I use RTSI 0 as trigger source. But it always reported error "Source terminal to be routed could not be found on the device"and Destination Terminal is: PXI_Trig0. I also tried routing RTSI clock to RTSI0, program runs and again it shows "Insufficient Signal Level on Reference Signal Increase: FGEN Amplitude". I am right now quite confused about what could be the problem. Attached is the code. The change that I made is in Initialize Scope.vi and Initialize Function Generator.vi. Thanks!

 

0 Kudos
Message 3 of 4
(3,057 Views)

You did not post the Initialize Scope.vi or the Initialize Function Generator.vi, so I don't know how the task is defined. Regarding the error you’re getting, do you have an error code or a screenshot of the error?

 

Have you tried using the niFgen Export Signals.vi? The “Example Software Overview” section at the link here, shows an example of how this VI is used to route a signal from your FGEN to the PXI Trigger Line. 

Tunde S.
Applications Engineer
National Instruments
0 Kudos
Message 4 of 4
(3,036 Views)