Showing results for 
Search instead for 
Did you mean: 

PXIe-4137 Error Code -235140 (self test code 268435457) when using RF


I have a system that involves several electrodes inside a vacuum chamber.  Some of the electrodes have an RF potential applied across them, others have DC potentials, and others are pulsed.  The pulsing happens using a set of PXIe-4137 SMUs.


The RF is a ramp that goes from about 100 volts to 2-3 kilovolts.  I just changed the RF frequency from around1.5 MHz to aroudn 3.5 MHz, which makes these electrodes draw a lot more power.  When I turned everythign on, one of the SMUs that is connected to a nearby electrode that is biased at -120 volts and pulsed to 0 volts produced an error (red light).  I could not get it to reset.  The error code it produced was as follows:


niDCPower Reset.vi<ERR>Internal Hardware Error occurred in Power_Supply hardware. Please contact National Instruments Support.

Self Test Code: 268435457

Component Name: nipsdp
File Name: .\source\nipsd\primitives\device\tAzraelDevicePrimitive.cpp
Line Number: 434

Status Code: -235140


I restarted the whole PXI chassis, and now the error is gone.  I don't understand what was different about just trying to reset the SMU.  The SMU now passes self test.


I don't really want to turn the RF back on if I might be risking the SMU, but I'm not sure what else I can do to protect it.  There is no direct connection from the RF electrodes to the electrodes that are pulsed, but the system shared a ground and some of the RF power couples to the electrodes around it.  If the SMU can't tolerate this, I'm going to have to find a different solution.  The other two pulsed electrodes are physically much closer to the RF than the one that produced the error, but they appear fine.  I can't find anything online about what this self test code means, so it's difficult to figure out how to start troubleshooting.

0 Kudos
Message 1 of 8

Hi stephencox,


A few questions/thoughts. Which LED light on the 4137 turned red? The Access or Voltage LED? Reference page 21 of the manual below for clarification on LEDs.


NI PXIe-4137 Specifications



I'd also like to ask what environment you are programming in (including version) as well as the version of NI DC Power driver that you are currently using. Where in your code does the error occur?


Lastly, I'm certainly glad to assist you as best as I can. Given the large factors at play in this issue, is it possible you could contact the Applications Engineering department and create a service request for this issue to coincide with this forum post?


Let me know what information you have for me and we'll go from there.




Finch Train

0 Kudos
Message 2 of 8

It was the voltage LED.


To start, it would be really helpful if someone could tell me what the error code means.  I would really love to know if this was some safety measure that I can ignore or disable, or if something is happening that could damage the hardware.


I'm using DCPOWER 15.1 and Labview 2015.  My card is in a PXIe-1078 chassis with a PXIe-8840 controller.  I can't properly see the controller in MAX, so my ability to change this configuration is limited.  I posted previously about these problems and never received any help (http://forums.ni.com/t5/Signal-Generators/Error-1074135024-Specified-file-cannot-be-opened-loading-b...).


As you can see, I got this error when I tried to use the DCPOWER driver through labview to reset the card (I tried several times over about half an hour before deciding to restart the box).  The error persisted with the RF turned off and even after I disconnected the front panel connection for the SMU.  In addition to the reset vi, the initiatize vi with reset enabled returned the same error.

0 Kudos
Message 3 of 8

I have opened this as service request #7514265.

0 Kudos
Message 4 of 8

Update: I am just proceeding.  I'm on a schedule here.  Resetting the device with "reset device" works when "reset" does not--I didn't realize that there were two software resets available to me in Labview.  And like I said above, I can't use MAX to do any of this.


I discovered that there appears to be an induced voltage on the lens from the RF.  It is so small that I don't notice it when the lens is connected to the SMU, but it gets up into the tens of volts when it has nothing but an oscilloscope connected.  I'm not sure if this is different from all the other metal around the RF electrodes, but I suspect not.


I tried setting the voltage range higher (I just set it to 200, the maximum) on the SMU, but that made no difference.  However, changing the bias voltage from -120 volts to -90 volts allows it to continue operating.  This is not the ideal situation for me at all, but I'm going to try to work with it for the time being at least.


It would still be really great to know what the device is trying to tell me.

Message 5 of 8



Glad to hear you've found a work around for the time being. The error indicates that one of the monitoring conditions on the device was tripped, though unfortunately it is not as descriptive as one would like. Given the variety of contributing factors, I've gone through and looked at limits of the device where you may be out of compliance. I'm curious if at any point you are exceeding the various limits of the device. The link below shows various limits of the device.


NI PXIe-4137



Can you provide more specific info of what you are specifically trying to output on the failed device and any spikes that may occur in the operation of your system?




Finch Train

0 Kudos
Message 6 of 8

The device is running at -120 volts bias voltage. Every 50 ms, it pulses to 0 volts for 5 ms on receipt of a trigger from a DAQ card in the PXI chassis.  I have the low side connected to the shield of a BNC cable that connects to the vacuum chamber that contains the lenses.  The high side obviously connects to the conductor.  This is just a single electrode floating in a vacuum chamber surrounded by ceramic insulators, so the amount of current it draws should be low.  However, there is a few watts of high voltage RF flowing through some electrodes nearby, and some of this undoubtedly couples to everything else in the chamber.  We think that the capacitance to this lens is less than a pF out of about 65 pF total.


Changing the bias voltage from -120 to -90 is what "fixed" the problem.  I am measuring it with a scope now, and it reads -89.7 volts.  When the RF was turned off, it was at -88 volts.  I can see the RF on the lens at about +/- 1 volt, but I see the same thing with the scope cable simply grounded to itself, so this might all be pickup on the scope cable.

0 Kudos
Message 7 of 8



Here is a clearer picture of what is going on.  I turned up the RF ramp a bit more and now cannot operate at -90 volts, either.  The blue trace is on the lens, now connected to the SMU, after the SMU went into the error condition and stopped output.  As you can see, the induced voltage on the lens is very nonlinear.  The green trace shows pickup on a grounded scope probe to measure the RF amplitude indirectly.  The actual amplitude at the top of the ramp is a few kilovolts.


So I gather that one of a few thing is happening.  Either the SMU is able to maintain its -90 volts output until it has to sink too much current from the lens, or it detects a transient overvoltage and then shuts off.  Since I don't see this effect while the SMU is operating, I am guessing that it is the former, right?

0 Kudos
Message 8 of 8