PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI realtime system configuration in MAX (unable to open tree + inconsistent IP settings)

Solved!
Go to solution

Hi,

 

I have a PXI RT system with a PXIe-8135 controller in a PXIe-1078 chassis. I am using LabVIEW 2020 SP1 (I cannot use a later version of LabVIEW since RT Linux does not support the 8135 controller and later versions of LabVIEW realtime only support RT Linux and not Pharlap). My version of MAX is 21.

 

When I try to connect to the PXI RT system from MAX, there are two issues.

1. I get the message "Inconsistent IP settings"

2. There is no arrow next to the PXI system to open the tree and look at device configuration, install software etc.

The following figure shows these two issues.

 

Fig1.png

My first question: Are the two issues related - is the tree arrow not showing because of the inconsistent IP settings?

 

Assuming this is the case, I followed the steps here: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P6WdSAK&l=en-US

 

I got to step 3.

 

After step 2 (changing the network configuration of the target to Static), the Network Settings tab looks like this.

 

Fig3.png

After step 3 (formatting the target disk and setting the network configuration to static again), the target screen looks like this:

Fig2.png

The two issues still persist.

 

My organization doesn't allow me admin access on the host computer. So, to try step 4, I need to get our IT people involved. Before doing so, I wanted to check if I am on the right track, in particular if not being able to see the tree arrow is related to the IP settings.

 

Thank you.

0 Kudos
Message 1 of 3
(280 Views)
Solution
Accepted by topic author mvsiva

Hello!

To configure the Real Time target, the host computer needs to be on the same subnet as the RT target. If the target’s IP address is 169.254.85.108 Subnet Mask 255.255.255.0, the host computer needs to have an IP address of 169.254.85.x – Subnet Mask 255.255.255.0.

You can change the target’s IP address to match the host computer. To do this, go to the Windows command prompt and type ipconfig to see your IP address and subnet mask. Set the target’s IP to something on the same subnet as the host computer, and then click save.

The target will connect and you will see “Connected Running” as the status. You may need to refresh MAX (F5 or view >> refresh). Now you can access the target by expanding the tree. If you cannot access the command prompt to see your IP address, you will need to contact your IT department.

Consider setting a static IP address for the host computer and the RT target to avoid connection issues after it is all set up- ask your IT department to do this for you.

Directions you might find helpful: 
Assigning an IP Address RT Target

Hope this helps!

Apex Waves Logo.png

0 Kudos
Message 2 of 3
(217 Views)

That did it! 

 

I had to change the IP address of the host (needed admin access for this) to a static IP in the same subnet as the target. Then the arrow showed up, and I was able to update the software.

 

Thank you!

0 Kudos
Message 3 of 3
(203 Views)