Showing results for 
Search instead for 
Did you mean: 

PXI: no devices (MAX), fail to connect or deploy

Go to solution



I have been trying to use a PXIe-8135 and according to MAX the status is "Connected - Running" but once I try to connect or deploy from the project it opens a dialog box saying "Fail to connect to the target". Also,  I cannot see any of the modules currently in the PXI on MAX under Devices and Interfaces.


Note: I am using LabVIEW professional 14.


Thanks for the help!

0 Kudos
Message 1 of 8



Just to make sure I understand everything correctly, are you working with an RT OS on the PXIe-8135? 

Daniel Parrott
Software Product Marketing - Data Management & LabVIEW
National Instruments
0 Kudos
Message 2 of 8

Hi Daniel,


Thank you for your reply. Yes I am

0 Kudos
Message 3 of 8

Just noticed an error. I am using PXIe-1065

0 Kudos
Message 4 of 8

So there could be a few things going wrong. 


1. Network Settings: Sometimes Firewall settings will interfere with LabVIEW communicating to RT target. I would go over these KB's and also try running the Real Time Discovery Wizard to make sure that all of your network settings are correct (especially in regards to your firewall.)


Why Can't LabVIEW Real TIme connect to an RT Series PXI on a Different Subnet?: http://digital.ni.com/public.nsf/allkb/86256A47004E16D186256A0F005F732B?OpenDocument

Real Time Target Discovery Wizard: https://decibel.ni.com/content/docs/DOC-39608


2. Software installed on the PXI: At the very least you should have LabVIEW Real Time (the version should be the same as the one you're using on your host PC) and PXI Platform Services installed on your PXI. 

This might also explain why you can't see any modules under your PXI in MAX. You'll also need to make sure any drivers needed for your application are also installed on the PXI. Make sure the Sys Config driver sets are also. 


These are my main thoughts. Let me know if these help out at all. 


Daniel Parrott
Software Product Marketing - Data Management & LabVIEW
National Instruments
0 Kudos
Message 5 of 8

Thank you very much for all the suggestions.


I downloaded the PXI Platform Services 14.1 and verified that I am running the same version of LabVIEW RT in both the host and target (PXIe-1065).

I cannot use the Real Time Target Discovery Wizard because it only supports CompactRIO, Single-Board RIO and myRIO targets. Also, I am attempting to connect the PXIe to the same network the host is connected to.


At this point I'm thinking it could be the firewall even though I did not have this problem when I connected the same host to the cRIO.

0 Kudos
Message 6 of 8
Accepted by topic author glovato

I just wanted to update this discussion since I finally resolved my issue and it may help people in the future.

Here is everything I did to get it working:

1)  swapped the ethernet cables on the PXIe

2) verified with the cmd that I could ping the target

using MAX:

3) uninstalled all the software that was already on the PXIe (because I was having dependencies' issues)

4) reinstalled the LabVIEW RT module on the system (making sure I download the PXI components)

5) installed the necessary components on the PXIe (verifying that both LabVIEW RT on the target and host have the same version)


After doing all of these I added the target to a project and could connect to it without problems.


Hope it helps!

0 Kudos
Message 7 of 8

Hello everyone,


It is my first time working on NI systems and I am currently encountering some issues to connect threw MAX application to the PXIe-8115 controller.

I do not know the IP address of PXIe-8115 controller and I am not able to add this remote system into MAX software.

I tried to use straight/crossover Ethernet cable, reset IP address using DIP switches located inside the controller , tried to see something using BIOS ... but nothing.

Can someone help me please ?

0 Kudos
Message 8 of 8