PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI-6221 not found

I've just been forced by local policy to upgrade to a new computer running Windows 7 (was on XP).  In MAX, I can see my PXI-1033 chassis, and the PXI-6511 and -6513 boards in slots 2 and 3.  There is a PXI-6221 card in slot 4, but MAX reports this slot as Unkown/Empty.

 

I am (sadly) running LV 8.5.1, as cost controls preclude upgrading to something more modern.  MAX tells me that my NI-DAQmx version is 8.7.1f2.  Is my problem as simple as needing to update NI-DAQ?  Or is it something deeper?

0 Kudos
Message 1 of 4
(4,770 Views)

Can you detect it if you swap the slot?

0 Kudos
Message 2 of 4
(4,761 Views)

1st make sure you can swap the cards like Katie mentioned. If it follows the card and it worked fine before the upgrade, then it may be due to the incompatibility with the OS and DAQmx. Note that the DAQmx version you have now does not list Windows 7 as a supported OS:

 

DAQmx 8.7.1 only lists up to Windows Vista:

http://joule.ni.com/nidu/cds/view/p/id/965/lang/en

 

NI-DAQ and LabVIEW Version Compatibility tells us we can go all the way up to DAQmx 9.3:

http://digital.ni.com/public.nsf/allkb/B0D5630C0A50D5C6862578E800459248

 

DAQmx 9.3 supports Windows 7:

http://joule.ni.com/nidu/cds/view/p/id/2337/lang/en

 

So therefore I would upgrade to DAQmx 9.3 to make sure that it's all good for your OS.

 

-Eric E

0 Kudos
Message 3 of 4
(4,747 Views)

Thanks!  DAQmx 9.3 threads the needle.  I'm back in business.

0 Kudos
Message 4 of 4
(4,742 Views)