PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI-1033 is not detected on PC Windows 10 MXI-express

We upgraded our computer and installed NI-DAQmx 19.5 and installed the MXI-PCIe card that connects to a PXI-1033 chassis but we just get the blue screen. If the cable is disconnected from the PXI, the computer boots. 

We have a Dell Vostro 5890 computer. The computer does not recognize the SMBUS Controller. It is not listed in the Device Manager. There is also only one PCI-to-PCI Bridge listed.

What we have tried already:
- 2 different PCIe slots
- versions 18.5 and 19.5 DAQmx software
- We have ensured that NI PXI Resource Manager is Running
- Installed NI PXI Platform Services
- Installed MXI-Express BIOS Compatibility
- Examined the cable to ensure no bends/damage
0 Kudos
Message 1 of 5
(355 Views)

Hi LVCU,

 

Can you confirm that you flipped the BIOS DIP switch on the PCIe card in addition to installing MXI-Express BIOS Compatibility? And have you tried without any cards in the PXI-1033?

 

- Robert

0 Kudos
Message 2 of 5
(325 Views)

Hi Robert -

We were using this PCIe-card on an old computer and simply moved it over to the new one. We did not change any switch on the card. The PCIe card is 8361. It does not seem to have a switch. 

0 Kudos
Message 3 of 5
(320 Views)

Hi Robert -


We just tested the Chassis without any cards (we use a PXI 6289 and a PXI 4461). The chassis works fine without the cards. Once we insert the PXI 6289, we can still start the computer but get the blue screen as soon as we go to NI MAX and click on the card. With the PXI 4461 in, the computer never starts up properly.

 

Any help would be appreciated!

Thanks-

0 Kudos
Message 4 of 5
(312 Views)

Hi LVCU,

 

What does the bluescreen message say?

 

You're right, the PCIe-8861 that shipped with the 1033 doesn't have a switch on it. Here are some other responses to your comments:
- There's not an SMBus controller on the 1033

- Since that PCIe-8361 has no bridges/switches on it, there will only be a single bridge in device manager (the bridge on the 1033 backplane)

 

I'd suggest disabling ASPM, which is a link power management thing that doesn't really save any power. To do that, search the start menu for "edit power plan", then click "change plan settings" for the plan that's selected (typically "Balanced"), then click "change advanced power settings).  In the list, expand "PCI Express" then "Link State Power Management". Set it to "off".  It may be easier to search the web for "advanced power options" to get pictures to go along with the description. Anyway, I hope that helps.

 

- Robert

0 Kudos
Message 5 of 5
(300 Views)