PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing drivers? FlexRIO Support for PXIe-5764

Hello,

 

I have an NI PXIe-5764 Digitizer card that I'd like to work with using LabVIEW FPGA. I followed the steps in the manual, but I think I might be missing a driver. I'd like someone to double check my steps or help guiding me.

The PXIe-5764 card is placed inside an NI PXIe-1071 Chassis. I am communicating to the Chassis using an NI PXIe-8381 card with express link to PCIe-8381. In MAX, I am able to see the NI PXIe-1071 Chassis and the NI PXIe-8381, but not NI PXIe-5764. Yesterday I downloaded and installed FlexRIO 19.0 and NI PXIe-5764 is shown as supported hardware. I checked NI FlexRIO Driver Supported Versions for FlexRIO Adapters and Modules for further compatibility, but I guess version 19.0 isn't listed. I think it is ok though since the 19.0 readme files mentions 5764 as supported hardware.

I revisited the manual for NI PXIe-5764 and noticed that I should install FlexRIO Support. I am struggling to find the driver/module I need. I found NI FlexRIO Adapter Module Support V3.4 but I don't think it's the one I need. I also found FlexRIO™ Support 18.1 Readme which does list PXIe-5764 as a supported hardware.

Is PXIE-5764 considered FlexRIO FPGA module orFlexRIO Adapter module?

Is FlexRIO 19.0 that I downloaded different than FlexRIO Support? I feel like it is and that I still need to find a FlexRIO Support module. I'm going to try FlexRIO Support 18.1 module.

Any help is appreciated, thank you.

0 Kudos
Message 1 of 6
(1,416 Views)

thej178,

 

I looked through the Getting Started Guide for the PXIe 5764 card and they mentioned to install the following software in this particular order: 

1. LabVIEW 

2. LabVIEW FPGA 

3. FlexRIO support 

 

Is this the order you have gone through? If not, I would recommend uninstalling the FlexRIO driver and going back to install the previous software. 

 

Hope this helps! 

0 Kudos
Message 2 of 6
(1,371 Views)

Hey, thank you for the response. I followed the correct order. I am not sure what the issue was, but I installed drivers for FlexRIO 18.7 available on the NI website and it worked! I don't know if something was missing from the FlexRIO 19.0 driver, but FlexRIO 18.7 seemed to have done it.

0 Kudos
Message 3 of 6
(1,353 Views)

Are you running Labview Linux Real Time v19.0? Because I am having the same problem of not detecting the card.

0 Kudos
Message 4 of 6
(1,249 Views)

@dcwill

Hey, no this was on a Windows Machine. I did not install LabVIEW Real Time of any sort, only the FlexRIO 19.0 drivers. Those didn't work for me. I don't know what the issue was to this day, but I decided to install FlexRIO 18.7 instead and that ended up solving the problem.

Since I went through the FlexRIO 19.0 installation first (and did not uninstall anything), running the 18.7FlexRIO driver installation ended up not being able to change the successfully installed 19.0 version software, but it also ended up installing some 18.7 packages that were missing from my computer. I think the 19.0FlexRIO driver was incomplete, hence why my card wasn't successfully detected and why installing the 18.7 version filled in the gaps of what was missing.

0 Kudos
Message 5 of 6
(1,217 Views)

FYI. There is a new version of Flex RIO available, version 19.5. I installed it and the PXIe-5764 is now detected in NI Max.

 

For anyone running Labview RT, I had to remove all the software from the embedded controller and then add all the software. When I tried to just update the Flex RIO driver, nothing seemed to get updated. 

0 Kudos
Message 6 of 6
(1,192 Views)