PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing devices in DAQmx dropdown

Solved!
Go to solution
Highlighted

I am trying to use the external SMB trigger on my PXI controller as illustrated in:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019Uu6SAE

But I don't see my controller listed in the dropdown menu for available devices. 

I checked the support for both my chassis as well as the controller with PXI Platform Services version and they show as compatible. It shows up fine in NI Max so I don't know what the problem is.

Is there a way to "refresh" the list of devices that LabView thinks are available?

Help!

0 Kudos
Message 1 of 6
(91 Views)
Highlighted

It looks like you have to type it in and not automatically listed down.

santo_13_0-1605983703431.png

 

-Santhosh
0 Kudos
Message 2 of 6
(54 Views)
Highlighted

I tried this but I get an error: "No device by the given name was found"

Lab_NI_Box.png

 

I can't update the problem description to reflect this

0 Kudos
Message 3 of 6
(36 Views)
Highlighted

Can you send in the code your using or a screen shot of the block diagram where the connection is being made? Also, can you send in a MAX Tech report? I'd like to look at how the connection is being made in LabVIEW as well as the naming and hardware of the devices being used.

0 Kudos
Message 4 of 6
(25 Views)
Highlighted

I am attaching the MAX tech report as well as a screenshot of the way the connection in made in the VI in question. The source code is also included in the zip file for the MAX report.

danzilla_0-1606244563550.png

 

0 Kudos
Message 5 of 6
(18 Views)
Highlighted
Solution
Accepted by danzilla

I was able to connect with NI support and got a resolution to my issue. Somehow the MAX configuration database got out of whack. I was able to see all the devices in the system after a configuration reset. 

 

Lab_NI_Box.png

0 Kudos
Message 6 of 6
(9 Views)