PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview Code migration from NI USB 8473 to NI PXI 8512

Hi,

 

I have an application code that making use of NI CAN USB controller ( NI USB 8473) for recieving the data from the device under test to the host pc. I would like to modify my code , by replacing the NI CAN USB controller with NI PXI 8512 (XNET 1.0 module).

I see in my code, have three vi files related to NI CAN, which makes use of the NI CAN library vi files to configure the CAN network, send a remote frame, receive all the remote frames and close the CAN network interface.

 

To migrate to the XNET device ( NI PXI 8512 module), I have installed the XNET1.0 package which included NI CAN compatibility layer that emulates the NI CAN function calls at the driver level.

 

After installing NI CAN 2.7.2 and XNET 1.0 with compatibility layer to support NI CAN library function calls, recompiling and generating an executable code, when  I run the executable code  ( which I have run succesfully using the NI CAN USB controller ) , I don’t see any CAN message receiving /acitivity on my host PC. It also doesn’t throw any error related to library mismatch(if incase ) or mismatch errors etc.

 

I am wondering, how as a user who is migrating fron NICAN to NI XNET can conform all the compatibility issues and what additional precautions should be taken to run the previous application labview code ( which had successful ran on the NI CAN USB controller )  to run using  NI PXI 8512 module.

 

Please let me know if you need additional information.

 

Please giv e your valuable inputs to move ahead.

0 Kudos
Message 1 of 3
(2,537 Views)

Hello,

 

We have a useful document that talks about migrating your application from NI-CAN to NI-XNET. Also is there a reason you did not install NI-XNET 1.1.1? This is our latest version of the driver, and will have bug fixes from previous version. Have a great day!

 

Best Regards,

 

Adam G 

National Instruments
Applications Engineer
0 Kudos
Message 2 of 3
(2,529 Views)

I could able to resolve the issue.

 

I need to change my port selection from CAN0 to CAN1.

 

NI CAN follows the convention of CAN0 and CAN1

where as the XNET follows the convention CAN1 and CAN2.

 

 

Since XNET with comaptiblity layer behaves as the NI CAN , I recompiled my code and then ran the application choosing CAN1. It worked fine.

 

Thanks for the help.

0 Kudos
Message 3 of 3
(2,523 Views)