PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Inconsistent IP Settings on PXI-8101

I am having an issue with connecting to my PXI-8101 controller in MAX. I recently updated the software on my developmental computer from LabVIEW 2014 to LabVIEW 2016, which of course came with new NI-MAX software. The next step was to update the RT software running on the PXI-8101 computer from what it is currently running (NI Real-Time Phar Lap ETS 13.1) to the LabVIEW Real-Time 2016.

 

Unfortunately, in the Remote Systems list in MAX, when I select the PXI-81081 (called "BioMag-PXI8101", see attached picture) the "Status" indicates "Inconsistent IP Settings". When I click on the dropdown arrow next to BioMag-PXI8101 in the navigation window (which would normally expand a list which includes "Software" and the other devices plugged into my PXI chassis), the arrow simply disappears and no options are present. However, I can still edit the items in "Network Settings" and successfully send restart commands - I just can't access the software in the dropdown.

 

Additionally, I can still right click on the device and open the web configuration. When I do this, the "System Settings" report the Status as "Running", and I'm able to view the hardware and software installed in the web configuration window...however I can't do what I really want, which is to install new software. Also, I'm able to access this device without issues (or inconsistent IP settings warnings) in MAX with another lab computer still running LabVIEW 2013 with MAX 5.6. So it seems to be a problem with the MAX 16.0 software more than anything.

 

Things I have tried: 1. Reinstalling LabVIEW 2016, 2. Formatting the hard drive of the PXI-8101 (after saving all data), 3. Using both DHCP and Static IP addresses. For these, I first let DHCP assign an address (my desktop and PXI8101 are both connected to our building's ethernet through a switch), and then later tried using those settings in a static configuration. No luck there.

 

Thank you in advance for any suggestions you can provide.


Zack

Download All
0 Kudos
Message 1 of 5
(2,537 Views)

The inconsistent IP warning is almost always an issue because one device has a DHCP address and the other has a link local address. I would try directly connecting the controller to your PC and assign the controller a static IP addresss in the link local range. Then try installing your software. You can then change it back to DHCP if you want that. Restart the controller and hook it back up to the router.

0 Kudos
Message 2 of 5
(2,503 Views)

Thank you for the reply, dgriffin. Does this require an ethernet crossover cable? I'm trying to locate one but haven't found one yet. The computer would not connect to it with a standard ethernet cable.

0 Kudos
Message 3 of 5
(2,495 Views)

Hi Zack,

 

I’m not immediately familiar with connecting to Real-Time targets, but I do know that you shouldn’t need a cross over cable for the PXI 8101.

 

I’ve attached a couple links that listed some troubleshooting steps you can try.

http://digital.ni.com/public.nsf/allkb/ABE4BC247E8AC9BC8625734E005CAB42

http://digital.ni.com/public.nsf/allkb/E67B4E4749F378FF862577270059BD4B

 

Again, I’m not really familiar with targeting an RT target, so I’m not sure how many of those steps will apply.

0 Kudos
Message 4 of 5
(2,478 Views)

If you have NI System Configuration 16.0 installed, there is a patch available that fixes the Inconsistent IP Settings problem and the related problems configuring targets from MAX. 

 

Please see NI System Configuration 16.0.1 Patch and install either update listed there.

 

0 Kudos
Message 5 of 5
(2,203 Views)