PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

How to install Windows 7 on PXI 8110 controller

Hi

 

I have PXI 8110 controller that is installed Windows XP on.

 

But I have to change the OS to Windows 7 SP1.

 

What should I do ??

0 Kudos
Message 1 of 9
(3,047 Views)

Sefaa,

 

According to the manual for the 8110, "The NI PXI-8110 supports the installation of Windows 7, XP, and Vista from a USB CD-ROM."

 

You will want to get an installation CD for Windows 7 and use an external CD-ROM drive.

 

Here are a couple more articles that talk about it:

http://ae.natinst.com/public.nsf/webPreview/C121B7EB066F078D86256D6A0062E317

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P7ZsSAK

 

VanCamp

0 Kudos
Message 2 of 9
(3,012 Views)

Sir, you are right. But I want to learn whether I can install Windows7 SP1 on the controller.

 

I am asking this question since I do not know the difference in between Windows 7 and Windows 7 SP1.

 

Note: To run Visual Studio 2017 on the PXI controller, I have to have Windows 7 SP1 at least.

0 Kudos
Message 3 of 9
(2,994 Views)

sefaa,

 

The only significant difference between system requirements for Windows 7 and Service Pack 1 is the disk space, which shouldn't be a big deal unless you've filled up most of the hard drive. It only requires a few extra gigs.

 

Here is an article that talks about the disk space differences: https://www.ghacks.net/2011/02/20/windows-7-sp1-all-you-need-to-know-and-do/

 

Hopefully that helps.

 

VanCamp

0 Kudos
Message 4 of 9
(2,990 Views)

Sir, for example I tried to install LabVIEW 2016 and LabVIEW 2017 softwares to a computer that has Windows 7 Professional today. But at the begining of installations, it gives me "It is required Windows 7 SP1 or later" error.

 

This can be given as an example for what I mention.

 

For Visual Studio 2017 software, it is required Windows 7 SP1 at least as well.

 

But I can only install Windows 7 / XP / Vista in NI PXI 8110 Controller.

 

I definitely have to install Visual Studio 2017 software in NI PXI 8110 Controller.

 

So, what kind of OS should I install to the NI PXI 8110 Controller??

0 Kudos
Message 5 of 9
(2,983 Views)

sefaa,

 

Why do you say you can only install Windows 7 / XP / Vista? This requirement for the controller most likely includes the service packs.

 

Have you tried installing Windows 7 Service Pack 1 on the controller? You should be able to.

 

VanCamp

0 Kudos
Message 6 of 9
(2,975 Views)

This is actually the asnwer of what I asked, sir.

 

I did not try to install Windows 7 SP1 on NI PXI 8110 Controller. But you say that I can install Windows 7 SP1. So there is no problem.

 

I will try and inform you about the result.

0 Kudos
Message 7 of 9
(2,973 Views)

Hi sir

I installed Windows 7 SP1 OS yesterday, so for now there is no problem. For your help, Thank you.

 

Now I have to install required drivers for the peripherals. I downloaded the drivers from this link http://www.ni.com/download/ni-pxi-8110-peripheral-drivers-1.0/1309/en/

 

to use NI DAQmx, NI Serial, NI VISA, NI Ethernet functions etc., is it enough to install the drivers above??

 

Or when I install LabVIEW 2017 software, these drivers will install automatically ??

0 Kudos
Message 8 of 9
(2,926 Views)

sefaa,

 

The peripherals does not include National Instruments drivers. They won't be included in LabVIEW either. You will have to install NI DAQmx, NI Serial, etc one at a time from our website.

 

Just do a google search for "NI-DAQmx 17 Windows 7" or whatever other drivers you need.

 

VanCamp

0 Kudos
Message 9 of 9
(2,918 Views)