Showing results for 
Search instead for 
Did you mean: 

Connecting multiple USB hard drives to PXI embedded controller

I would like to connect multiple (two) USB external hard drives to a PXIe-8130 controller and record data to these drives. It would also be nice to connect even more, as a workaround to the 126 GiB partition limitation, which was also a disappointing limitation.



Looking at this page FTP Transfer of Files between Host and Real-Time Targets in MAX,  I see that the USB drive mounts at u: .  Is it supported to connect more than one?  I tried plugging in another drive and typing v:, and it didn't give me an error, but it didn't show the drive contents.  Also, on the PXI console, I got a warning:


WARNING: flush from cache to disk failed - data discarded.




0 Kudos
Message 1 of 10

After restarting the system, I see that both disks do show up at U: and V:, but there seem to be problems with caching as I still see the contents of one drive even after it's disconnected. 


Can I get any pointers to KB articles or manuals on the relevant topics of  USB support, known issues, etc.?

0 Kudos
Message 2 of 10

From your first post it seems like you're running Real-Time on your controller... can you verify this?

If you plug in your USB drive to a different machine, do you see this same behavior? Try running scandisk on your drive to see if there are any issues with the drive itself.

Justin E
National Instruments R&D
0 Kudos
Message 3 of 10

Yes, I am running the real-time operating system.  I am not running Windows XP. 


These disks are known good, just formatted as FAT32 126 GiB to appease the limitation (even though they are actually much bigger than this).


As mentioned in the 2nd post, I have discovered that if both drives are already connected before the system boots, both drives will appear normally.  But hot-plugging does not appear to behave as expected. Is this a known limitation?



Furthermore, the most distressing limitation that I have just discovered is that I am unable to open a file on each of the U: and V: drives, and write to them.  My VI will write for a short time, then it seems to hang inside the loop that is writing the file.  When I change the location of the file to be either on the same USB drive, or on the internal hard drive and on a USB drive, or back to both on the internal hard drive, the VI behaves properly and processes the writing normally.


I have tried plugging the USB HDs in different combinations of front-panel USB ports.  Namely, I first tried the 1st leftmost and 2nd leftmost, as well as the leftmost and 3rd leftmost.


Is this a known limitation? There's a chance that there's a problem in my prototype application code, but the experiment above seems to suggest otherwise.

0 Kudos
Message 4 of 10

Another issue that I experience:


1. I plug in both USB drives.

2. I power on the PXI controller (realtime OS)

3. I deploy and start my VI, which opens files C:\ni-rt\labview data\serialxxxx.dat and V:\serialxxxx.dat

4. On the windows host that is deploying the app to the realtime box, the error handler tells me: "Error 7 occurred at Open/Create Replace File in aqn.vi.  Possible Reasons: (....)  v:\serialxxxx.dat"

5.I repeat step 3, and then it works without error.


It seems like it has trouble mounting the drive for the first time.  Does something need to be sequenced to make this not happen?

0 Kudos
Message 5 of 10

I realize that this thread is mostly about resolving your USB issues, but another resolution you might consider is upgrading to LabVIEW Real-Time 2009.  Starting with this version, the disk size limit has been increased to support disks up to ~2TB in size on a real-time target.

0 Kudos
Message 6 of 10



Thank you for the information.  Right now we are very close to a product deadline so I think we will be hesitant to try this right now for the larger disk space only.  


However, if it turns out that many of the USB issues I've described so far are actually addressed, it would be something to consider.

0 Kudos
Message 7 of 10
Is Labview 2009 the same as Labview 9.0.1?
0 Kudos
Message 8 of 10
In case you're wondering why I'm asking, it's because the university dept has a download site with installers for Labview 9.0.1
0 Kudos
Message 9 of 10

It turns out that having large disk support was enough reason to make the switch, so I upgraded to Labview 2009 that today. 


Actually, this appears to have solved the issues of large disk support, the write caching error messages, and the inability to write to two USB hard drives.


I think the few remaining issues are minor hotplugging issues, as well as the one dealing with the initial mounting of the drive.



So it's possible that everything really I need is taken care of by upgrading to 2009, but I'll have to do some more testing tomorrow.



Message Edited by gregoryng on 09-29-2009 08:33 PM
0 Kudos
Message 10 of 10