Showing results for 
Search instead for 
Did you mean: 

Cannot install VeriStand RT Engine 2021 on PXI Target

Go to solution

We have a PXIe-1088 chassis with a PXIe-8880 controller currently running PharLabs as OS. On our host we updated LabView+Veristand from 2019 to the most recent version (2021 R2). We updated the drivers on the PXI-target accordingly but the VeriStand RT Engine is missing and it cannot be installed (it does not appear in MAX when clicking on "add/remove software"




I would appreciate feedback how to solve this problem. 


P.S. We noticed two things:

* The installed LabView application is a 32bit application while VeriStand is 64bit. In the past we made the experience that 64bits together with RT-targets does not work very well!

* Could this issue be linked to the OS which is PharLab which might not be supported anymore?

0 Kudos
Message 1 of 3
Accepted by topic author Martin_R.

In fact, it turned out that the problem arises due to the fact that PharLabs is not supported anymore:


VeriStand 2021 R2 Readme




0 Kudos
Message 2 of 3

For those who have the same problem and need to replace PharLabs here some notes about how I did this: 


Update BIOS:

  • Following the description on Provisioning a PXIe Controller to the NI Linux Real-Time Operating System - NI I figured out that I also have to update the BIOS of my RT target. Otherwise I cannot install Linux RT!
  • I downloaded the zip-file and tried to execute “CreateUSBUtilityDisk.exe” as described in the instructions. However, this tool complained that it cannot format a flash drive having more than 1 partition. I checked the partitions and actually there was a second EFI-partition on the drive. Unfortunately this one is protected from deletion by Windows. However, I could remove the EFI-Partition using diskpart in Windows. (See for example How to Delete EFI (System) Partition in Windows [2 Ways] - EaseUSMartin_R_1-1651830999146.png)
  • Once I had the flash drive prepared for the BIOS update I followed this description here (note: Description is specific to my controller. Eventually you need to follow a different one): PXIe-8880 Firmware and Additional Drivers Readme - National Instruments (ni.com)Martin_R_2-1651830999146.png


  • However, preparing the BIOS according to this description was not so easy:
    • First of all “NI Linux Real-Time” was not available as option.
    • Also, although I changed the USB settings according to the description they were always reset and booting from flash drive was not possible.
  • Only once I selected “Windows/Others” as operating system under Advanced/Boot»LabVIEW RT Configuration»LabVIEW RT Operating System (instead of the “NI Linux Real-Time” which is mentioned in the description), I managed to set the USB settings according to the description. Once this worked, I could also boot from the flash drive 😊
  • Following the further steps of the description I could update the BIOS.


Replace OS on Target:

  • Next step, replace PharLabs on the Target following this description here: Provisioning a PXIe Controller to the NI Linux Real-Time Operating System - NIMartin_R_3-1651830999147.png
  • Upon configuring the BIOS according to the description I rebooted but received the following message: “Invalid system disk. Replace the disk and then press any key”
  • I tried all the USB ports but received always the same message. So I thought maybe I have the same problem as when upgrading the BIOS and removed the EFI partition from my flashdrive formatting it with just one single partition. This looked as follows:



  • Upon creating the NI-Linux Recovery disk from MAX again, the drive looked as follows:



  • With this flash drive installing the Linux RT OS worked fine.


Install Base Image:


Next problem: The target boots and I can find it via MAX but since it boots in safe mode I cannot install any software! I get to the login window where I enter "admin" and "{password}" to login. But then I get a message that no software can be installed when the target is in safemode. So I try to follow the "offline installation guide" here: Installing Software to Offline NI Linux Real-Time Targets - NIMartin_R_8-1651830999148.png. I followed the instructions and tried this a couple of times but either the "install software" option was disabled or MAX had issues to find the RT target. I was also puzzled by the screenshot of the instruction where it looks as if the target is not connected while installing the software (therefore the red x on the target). However, at some point it worked. This was the following situation

  • RT target running. I logged in on the console as admin.
  • NI Max opened on the host PC

From there on I simply followed the description and completed the base image installation.



0 Kudos
Message 3 of 3