Showing results for 
Search instead for 
Did you mean: 

Calibrating PXIe-4353 using CAL-4353 and a temperature calibrator (Martel PTC-8010)

Go to solution

And I have another silly question. The calibration manual requires a calibrator that can output 70mV and -70mV. But the calibrator that I use can output 70mV and only upto -10mV. If I set the calibrator to output 70mV and if I reverse the connections, would the new output be equivalent to -70mV.


0 Kudos
Message 11 of 17

I had mailed NI support regarding the error and got the following response -

"Error - 201368 occurs because the program takes in only one calibration point(+70 mV), but two (both +70 mV and -70 mV) are required.

It seems that a state machine would be a required to accomplish this and several steps in the procedure require waiting (such as switching from + to -). This would allow the program to respond to the states and perform several tasks consecutively."


I am trying to figure out and build a VI with the state machine logic.


The logic is as follows -

1. The user inputs a +70 mV to CAL-4353 and the external calibration adjustment is done by selecting the DAQmx Adjust 4353 Calibration VI.

2.1. The user inputs a -70 mV to CAL-4353 and the external calibration adjustment is done by selecting the DAQmx Adjust 4353 Calibration VI.

3. Save adjustment constant to EEPROM by selecting action to commit in DAQmx Close External Calibration VI.


Any help on implementing the same would be appreciated.


P.S -  -70 mV can be obtained by reversing the connections of +70 mV.


0 Kudos
Message 12 of 17

I think moving forward with NI support is a good idea.  At this point, I’m not sure what the root of the error you are experiencing is. 


When you find a solution, you should post to this thread so others who encounter the error in the future can use your solution.

0 Kudos
Message 13 of 17

The error is due to the program taking only one calibration point instead of two as required in the calibration manual.

I tried changing the program to get two reference voltages but I keep getting the error - 50103 that says that the resource is reserved in LabVIEW.

I had the same error initially when I the program was taking only one calibration point, but it was resolved when the device was reset in NI-MAX.

I am not clear how the two calibration points are stored and sent to the Close External calibration VI when the action is set to "commit".

I will post an update when/if I find a solution to this problem and any help to solve the same would be appreciated.

0 Kudos
Message 14 of 17
Accepted by topic author Hprasan

I got the calibration VI working now.. I had the DAQmx adjust SC calibration accessory VI and its reference, physical channel inputs in a while loop and ran the loop twice with +70 mV in the first run and -70 mV in the second run and the VI ran without any errors.

Then I checked the calibration date in NI MAX and it seems the device had been externally calibrated 🙂




0 Kudos
Message 15 of 17

That's great to hear.


If you can, post the working code, so others with this issue in the future can see the solution.

0 Kudos
Message 16 of 17

Sure 🙂 The working code is attached

If the run VI is clicked the VI throws an error. I used step into buttons to go through the subVIs one by one and clicked stop button in the front panel after the first iteration of the while loop and changed the reference value and the output of the calibrator to -70 mV so the while loop executed once more and passed two calibration values to the DAQmx close external calibration VI.


0 Kudos
Message 17 of 17