NI VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Veristand 2017 deploy timeout after upgrade to Win10ultimate

Hello,

I ran a PXIe8840 on Win10pro. Due to company regulations, I had to upgrade to Win10ultimate and the host name was changed. Everything else stayed the same, but now Veristand reports an error when deploying the project ("Timeout"). The ping works fine. According to MAX the system is working ok. This is the original message - can someone please give me a hint to solve the problem?

 

• Start Date: 04.11.2020 14:34
• Loading System Definition file: D:\Projekt\Test_M_RT.nivssdf
• Initializing TCP subsystem...
• Starting TCP Loops...
• Stopping TCP loops.
Waiting for TCP loops to shut down...
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
The VeriStand Gateway encountered an error while deploying the System Definition file.

Details:
Error -307660 occurred at Project Window.lvlib:Project Window.vi >> Project Window.lvlib:Command Loop.vi >> NI_VS Workspace ExecutionAPI.lvlib:NI VeriStand - Connect to System.vi

Possible reason(s):

NI VeriStand: Timeout beim Übertragen einer neuen Systemdefinitionsdatei auf das Zielsystem.
=========================
NI VeriStand: NI VeriStand Gateway.lvlib:VeriStand Server Wrapper.vi >> NI VeriStand Server.lvlib:NI VeriStand Server.vi

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
• TCP loops shut down successfully.
• Unloading System Definition file...

0 Kudos
Message 1 of 8
(361 Views)

Where is your VeriStand application running on? The Windows PXI Controller or other RT system?

Does creating blank project resolve the deployment issue? Is an IP address changed?

 

 

In English, the error said...

 

Error -307660 occurred at an unidentified location

Possible reason(s):

NI VeriStand: Timeout occurred while deploying a new system definition file.

Emboar
Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 2 of 8
(339 Views)

Thank you for your reply!

Since I am not sure which information is necessary to analyse the system behavior, I try to povide some details which I think are relevant.

My system consists of a PXIe-1065 chassis hosting a PXIe-8840 controller and some components like a CAN interface (PXI-8512), current/voltage IOs (PXIe-4300, PXIe-4322) and others in order to enable RT testing.

VeriStand is installed on the Windows PC which I use to configurate and deploy the projects to the PXIe-8840.

In the MAX (Measurement & Automation Explorer) the state of the PXIe-8840 is "in operation". All settings (including the IP-address) of the PXIe-8840 are the same as before the upgrade to Win10 Enterprise (sorry for the error in the topic) and integrating the PC account to the company domain. The Windows firewall is deactivated and the PXIe-8840 reacts to ping - therefore I assume that at least the connection is set up properly.

I now created a blank project and... yes, deploying a blank project works fine.

What do you suggest to do or check next? Thank you for your help!

0 Kudos
Message 3 of 8
(305 Views)

@SmartM_tester wrote:

I now created a blank project and... yes, deploying a blank project works fine.

What do you suggest to do or check next? Thank you for your help!


It implies NI VeriStand is working well, software fix or uninstall steps are not required I believe.

Please check following points.

 

  1. Open the system definition file
  2. Select "Controller" on left side pane
  3. Are "IP Address", "Operating System" correct? Does firewall block the ip address?
Emboar
Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 4 of 8
(290 Views)

I don't know what exactly does Windows 10 (in the configuration my company uses) do differently than Windows 7 - however it now works when Veristand is executed with administrative privileges. Thank you for your efforts to support me.

0 Kudos
Message 5 of 8
(275 Views)

I guess Firewall prevent communication between Windows and NI VeriStand.

It allows the communication as Admin but not as other user.

Emboar
Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

GCentral
0 Kudos
Message 6 of 8
(265 Views)

If it can help, there is a topic for firewall configuration here:

https://www.ni.com/fr-fr/support/documentation/supplemental/10/configuring-software-and-hardware-fir...

 

You may have to configure some of your advanced firewall settings if your company policies allows it.

 

Regards

0 Kudos
Message 7 of 8
(257 Views)

In my case the firewall is deactivated completely. Nevertheless it was necessary to execute Veristand with administator priviledges in order to solve the "Timeout" problem.

0 Kudos
Message 8 of 8
(224 Views)