NI VeriStand

Showing results for 
Search instead for 
Did you mean: 

Large Model Times Out During Deployment

Go to solution

While doing some testing with NI VeriStand 2017, I've added a model to my system definition that is about 96 MB.  When I go to deploy the system definition, it times out in about 60 seconds trying to download this file to the PXI.  If I check the PXI via FTP (ftp://192.168.0.x/ni-rt/NIVeriStand/Models/), I can see that the model file is 70 MB.


* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
The VeriStand Gateway encountered an error while deploying the System Definition file.

Error 56 occurred at Project Window.lvlib:Project >> Project Window.lvlib:Command >> Project Window.lvlib:Connect to

Possible reason(s):

LabVIEW:  The network operation exceeded the user-specified or system time limit.

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *



We successfully use this model with our other systems that are running 2013 SP1, I've never seen a timeout while transferring models to the RT.  Other than the version, the hardware is different.  In our 2013 SP1 setups we use the NI RMC-3854 and in our new system we are using an NI PXIe-8880.


Anybody have any ideas?

0 Kudos
Message 1 of 13

Hello NathanJD, 


Are you on the same network in both cases (with the RMC and 8880)? What happens when you remove the model from the system definition file, can you deploy it?



Applications Engineer 

0 Kudos
Message 2 of 13

The network configuration is the same on both the RMC setup and the PXI setup but they do not exist simultaneously in the same system.  They are on a secondary subnet (


If I remove the model, everything works.  If I add other models from the RMC setup, they work just fine on the PXI setup (the other models are quite small relative to the large one (less than 6 MB).


One big difference is that 2013 SP1 uses FTP and 2017 uses WebDAV so I was wondering if something about WebDAV could affect the files transfers.  I found a registry entry that claims to be a WebDAV limit but increasing that didn't help.



0 Kudos
Message 3 of 13

WebDAV does have a 50 MB file size limit, so that could definitely be what you are running into. When you said you tried changing a limit, were you changing the registry based on this KB article?




0 Kudos
Message 4 of 13

That is the registry entry that I changed.  However, I wasn't really all that convinced that that was the issue because the size of the model on the real-time controller is ~70 MB (~77%).  So, it was already able to transfer more than the supposed 50 MB limit.

0 Kudos
Message 5 of 13



It is possible that we are just not giving the deployment enough time to transfer the file completely. Can you try increasing the timeout for your VeriStand project deployment? To do so:

  1. Open your VeriStand project.
  2. Right-click on your project in the project tree (.nivsproj item) and select Properties.
  3. Select VeriStand Gateway.
  4. Change the timeout value to wait indefinitely.

Also, do you have any antivirus software on this PC? I've heard of another case where a large file-transfer over webdav was being blocked by AV software such as Simantec Endpoint.

0 Kudos
Message 6 of 13

The timeout listed in the project properties was 120,000 ms (120 s).  When I changed it to indefinitely, the behavior was still the same.  Also, the transfer times out in 60 seconds (not 120).  So, it looks like this isn't the case.


The company I'm working with requires AnitVirus software on all of it's PCs.  I may have to contact IT to see what I can do to test this theory and what they can do if it turns out to be this (i.e. if it's in the protocol to allow such an exception).

0 Kudos
Message 7 of 13
Accepted by NathanJD

FYI, while working with NI via support ticket, they found the bug that was causing this and it's an issue internal to NI VeriStand (the WebDAV transfer has a hard coded timeout of 60 seconds).

Message 8 of 13

Hi Nathan,


Do we know if this issue was fixed in any veristand patch?

Did you get any workaround for this problem?

Guillermo Oviedo
0 Kudos
Message 9 of 13

Hi Guillermo,


I believe that this bug was fixed in VeriStand 2019 R3.



Message 10 of 13