cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Invalid templates error

Invalid templates error

Hello,

 

Versions: VeriStand 2011SP1

 

When launching the workspace window, I get an "invalid templates ... error" (see attachement). That's because someone have used a custom symbol of his own in one of the screens and finally deleted it from its repository before deleting from the workspace window. I've tryied to remove them by using the "Manage Screen Items" form: I removed all items in error and saved the workspace, but I still have the error at launch time.

 

I wonder if there is a mean (knowing that I don't have the the custom symbol anymore) to correct that without redevelop the screens from scratch.

 

Best Regards

0 Kudos
Message 1 of 10
(5,135 Views)

Re: Invalid templates error

It sounds like you're doing everything right by using the "Manage Screen Items" tool.

 

If there are no missing links in that tool then you should not be getting that error.

 

Is that much of a problem to remake the workspace? You mention not wanting to have to make it from scratch, but it would likely resolve the error.

 

Otherwise, could you post your .nivsscreen file? Perhaps a second look at it may provide some more insights.

Craig H. | CLA CTA CLED | Systems Engineer | National Instruments
0 Kudos
Message 2 of 10
(5,051 Views)

Re: Invalid templates error

I did the same procedure (using the Manage Screen Items, and I've not invalid link) but still I've the message when I open my workspace.

I attach my .nivsscreen file to see if it can help.

 

Regards

Domenico

0 Kudos
Message 3 of 10
(5,039 Views)

Re: Invalid templates error

Hi,

 

Sorry for the delay, here joined a workspace file. Have any fix been posted to another thread ?

0 Kudos
Message 4 of 10
(4,876 Views)

Re: Invalid templates error

Thumble,

 

Did you ever find a solution to this problem?  I am getting the same "invalid template" error when launching the workspace.

0 Kudos
Message 5 of 10
(2,346 Views)

Rif.: Invalid templates error

Hello,

I have the same problem... I'm working on VS 2015 and I have no issue on the Manage Screen Items. I tryed to delete all the controls/indicators and I received the same error.

 

Tks,

Fabio

0 Kudos
Message 6 of 10
(2,198 Views)

Re: Invalid templates error

Hi,

 

The only solution we've found was to remake the screen.

 

I can imagine there are no simple way to correct the issue because the file content seems to be a binary serialization of an object graph and unless adding a fine control of the deserialization this won't work if some class are missing.

 

Best regards

0 Kudos
Message 7 of 10
(2,195 Views)

Re: Invalid templates error

Smiley Sad

 

thanks!!!

0 Kudos
Message 8 of 10
(2,191 Views)

Re: Invalid templates error

All,

 

I was able to find a solution without remaking the entire screen.  In my situation, I deleted an a workspace display item from it's root folder (C:\Users\Public\Public Documents\National Instruments\NI VeriStand 2015\Display Templates) before deleteing it from the workspace.  This caused the "invalid template" error to appear when opening the Workspace.  I looked in the "Manage Screen Items" menu option, but didn't see the item I wanted to delete, thus couldn't fix the issue.  I then decided to re-add the missing item to the root folder.  I placed the item back in the Display Templates folder, then opened VeriStand, and selected the "Manage Screen Items" menu option.  This time, the item I was trying to delete appeared with a red x next to it.  I chose to delete it, and that fixed the problem.  After that I could delete it from the root folder, and everything was fine. 

 

I hope that helps.

0 Kudos
Message 9 of 10
(2,136 Views)

Re: Invalid templates error

I was able to fix the same issue on my VeriStand 2017 screen with this. Thank you

0 Kudos
Message 10 of 10
(249 Views)