NI VeriStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Building model for Linux RT target from VI

Hello All,

I feel like I'm missing something easy.  Having trouble building a vi for running in a LINUX RT target.  MAYBE I MUST install LabVIEW x64 to build vi's for x64 Linux target?

 

LabVIEW2020:

beavercreek_3-1638287155178.png

VeriStand 2020R5:

beavercreek_4-1638287211545.png

Windows10

beavercreek_5-1638287254286.png

 

 

 

beavercreek_1-1638287011787.pngbeavercreek_2-1638287026926.png

 

0 Kudos
Message 1 of 13
(909 Views)

You should be fine with LabVIEW 32-bit. Do you have LabVIEW Real-time installed also?

Darin Gillis
NI - Chief Product Owner - VeriStand
0 Kudos
Message 2 of 13
(893 Views)

beavercreek_0-1638293125226.png

 

Indeed, I can successfully build for PHarLap targets as well.  RT Chassis is currently still PharLap, hoping to move to Linux shortly.

0 Kudos
Message 3 of 13
(881 Views)

There are a few other software packages I would recommend checking that you have installed that are outlined in this KB: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000001Dd2LSAS&l=en-US. Since you can compile for Phar Lap, my first guesses would be the C/C++ dev tools for Linux. Outside of those installations, I would also recommend ensuring you have LabVIEW RT and Application Builder licensed.

Brian.D
NI Product Owner
VeriStand
0 Kudos
Message 4 of 13
(872 Views)

This was one of my confusion points... no 2020 version listed, roll with 2017?

 

beavercreek_0-1638298568368.png

 

0 Kudos
Message 5 of 13
(865 Views)

Correct. We include that as an optional dependency with the VeriStand suite. Once you have that installed, you should not need to interact with the Eclipse environment directly, as the LabVIEW Model Generation will handle the compilation behind the scenes.

Brian.D
NI Product Owner
VeriStand
0 Kudos
Message 6 of 13
(859 Views)

Well...

I installed and followed along far enough to successfully build the Hello world C project.  Went back into LabVIEW and have the same failure message.  I note when I open one of the created VI's, its broken.  Perhaps that is a normal condition?

 

I would guess that VeriStand is looking at some of the eclipse registry keys to figure out where GCC is located in the file system?

 

PATH=

C:\Program Files (x86)\Common Files\Oracle\Java\javapath

C:\Program Files\National Instruments\Shared\OpenVINO\
C:\WINDOWS\system32
C:\WINDOWS
C:\WINDOWS\System32\Wbem
C:\WINDOWS\System32\WindowsPowerShell\v1.0\
C:\WINDOWS\System32\OpenSSH\
C:\Program Files\TortoiseSVN\bin
C:\Program Files (x86)\imc\Shared
C:\Program Files (x86)\imc\shared
C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin\
C:\Program Files\IVI Foundation\VISA\Win64\Bin\
C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin
C:\Program Files\IronPython 2.7\
C:\Program Files\dotnet\
C:\Program Files\Microsoft SQL Server\130\Tools\Binn\
C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL
C:\Program Files\Intel\Intel(R) Management Engine Components\DAL
C:\Program Files\WindowsPowerShell\Scripts\HP.ClientScriptLibrary
C:\Program Files (x86)\National Instruments\Shared\LabVIEW CLI
C:\Program Files (x86)\IVI Foundation\IVI\bin
C:\Program Files\IVI Foundation\IVI\bin
C:\build\17.0\arm\sysroots\i686-nilrtsdk-mingw32\usr\libexec\arm-nilrt-linux-gnueabi\gcc\arm-nilrt-linux-gnueabi\4.9.2
C:\build\17.0\x64\sysroots\i686-nilrtsdk-mingw32\usr\libexec\x86_64-nilrt-linux\gcc\x86_64-nilrt-linux\4.9.2

 

beavercreek_0-1638305895861.png

 

0 Kudos
Message 7 of 13
(855 Views)

I've not been able to build on three different machines.   Maybe someone could create a VI to check the file system for expected components?  or also check the registry for expected keys/paths?

 

beavercreek_0-1638386360475.png

 

0 Kudos
Message 8 of 13
(838 Views)

Does clicking on the Linux x64 target (warning icon) provide any additional information? If you have LabVIEW Real-Time module installed and activated, perhaps the CompactRIO driver is what is causing the issue.

Brian.D
NI Product Owner
VeriStand
0 Kudos
Message 9 of 13
(834 Views)

Ack... Success!  I installed ni-labview-2020-rt-module-x86_20.0_online_repack3  (even though it was already reported as installed) and off it went.  Will try same fix on build system #2

 

 

beavercreek_0-1638391491883.png

 

Message 10 of 13
(832 Views)