NI VeriStand

Showing results for 
Search instead for 
Did you mean: 

ASAM Steps : VeriStand is not installed

Go to solution



I just installed VeriStand 2018 SP1 + TestStand 2017 SP1 + ASAM Steps. I'm building a basic sequence to get started, and I get a message when configuring Framework Create step, I get the following message : "VeriStand is not installed"


Here is a screenshot :VeriStand is not installedVeriStand is not installed



I already uninstalled and reinstall the ASAM steps, it does not change the issue.


I just start investigations arround this issue, if any had already encounter (and solved) it, any suggestions is welcome !



0 Kudos
Message 1 of 7

Which software bitness are you using?

TestStand provides both 32-bit and 64-bit version. Why don't you change the bitness?

(I have no confidence but...)

Certified LabVIEW Developer
There are only two ways to tell somebody thanks: Kudos and Marked Solutions

Message 2 of 7

Hello Emboar, and thanks for your answer.

My customer installed TestStand 32-bit. I would prefer find out why the ASAM Steps do not detect VeriStand, or a way to make it detect properly before starting changing my plan on bitness.


Changing to TestStand 64-bits implies others problematics regarding code modules. It is not something impossible, but this has a consequent implications.



0 Kudos
Message 3 of 7



VeriStand uninstalled, then reinstalled (reboot), no changes in TestStand.


Digging further into the issue, the Post-Step sub step of NI_FrameworkCreate Step cannot load properly, indicating that a module cannot be loaded :





Some of the classes in this assembly might not be available because of the following error. To force a refresh of the information for this assembly, select File>>Unload All modules.
Could not load file or assembly 'TSDotNetSupport, Version=, Culture=neutral, PublicKey=ad9244eb3b825cd8' or one of its dependencies. The system cannot find the file specified).


Is the sub-step expecting only TestStand 2017 .Net support files, while I'm using 2017 SP1 ?



0 Kudos
Message 4 of 7

New element.


We use for other projects compoteurs with TestStand 2017 (no SP1) and VeriStand 2018 SP1. In this condition, the step is working properly.


The assembly NationalInstruments.ASAMXilSteps.Core.dll is present on the computer, as well as TSDotNetSupport.dll... but in version


This let me think that ASAM steps are not build to support TestStand 2017 SP1, requiring a specific version of TSDotNetSupport (


And perhaps TestStand 2019 is also impacted the same way. Does anyone already tried TS2019 + VS2018SP1 + ASAM Steps ?


Note I'm using the last available Steps, you can find here : VeriStand 2018 ASAM XIL Steps for NI TestStand

(package name : ni-asam-xil-teststand-steps_1.0.0.49152-0+f0_windows_x64.nipkg)



0 Kudos
Message 5 of 7
Accepted by topic author Mathieu_R.

Hi there,


I was wrong yesterday, TS 2017 + VS 2018 SP1 is not functionnal. Sorry about this mistake.


The NI french support noticed me that, as mentioned in, as mentionned in ASAM XIL Steps for NI TestStand (and the NI french support pointed me, thanks !) the only supported versions for theses Steps are TestStand 2017 vs. VeriStand 2018. Strictely.


Note that NI Package manager as absolutely no problem, and do not warn you on anything, installing it for TestStand 2017 SP1 and VeriStand 2018 SP1, althougt this combinaison will not work. The package could be updated to check more sticetly the software prerequisite, and do not allow to install if Veristand is not 2018, and if TestStand is not 2017.


The only workarround for now is to downgrade to VeriStand 2018 / TestStand 2017. And rebuild all of my UI Manager screens (not supported by previous version).

Message 6 of 7

I need to stick with Veristand 2018sp1 or newer. What are my options for controlling my Veristand project from teststand?

0 Kudos
Message 7 of 7