NI VeriStand Add-Ons Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Scan Engine & EtherCAT Custom Device Feedback

You are most likely missing a necessary driver which makes the VI unable to be executed on the target. I would suggest ensuring that you have installed the EtherCAT driver to both your PC and your RT target.

 

If you have further questions/concerns, this custom device is now officially supported by NI. You can get support by either creating a service request (ni.com/support) or filing an issue on the source code located on GitHub: https://github.com/ni/niveristand-scan-engine-ethercat-custom-device.

0 Kudos
Message 671 of 676
(1,431 Views)

Hello csparksfly

Please find the attached images of software installed in host pc and RT.

I am using cRIO 9076

When I observed the software list I come to know NI- Industrial communication for EthercaT17.0 is resent in Host pc but not in RT(by going through web cRIO 9076 doesn't support for Ethercat FPGA and Scan mode). I want to know whether this is the reason I am not able to deploy in Verisand

 

Thank you

0 Kudos
Message 672 of 676
(1,425 Views)

Looking at your screenshots, you do not have the EtherCAT driver installed on either machine. You first need to download and install the driver to your PC and then you will be able to install it to your target.

 

You can get the 17.6 version of the driver which should be compatible with the rest of your software here: http://www.ni.com/download/ni-industrial-communications-for-ethercat-17.6/7180/en/.

0 Kudos
Message 673 of 676
(1,420 Views)

Hello

In the host NI industrial communication for EtherCAT 17.0 is installed(Please find the attached image) but in the target, I am not able to install because cRIO 9076 doesn't support EtherCAT. But I am not using any EtherCAT for my project, So I feel it is not required. Please let me know if this issue causing the problem or any other issue. Looking forward to hearing from you

 

Thank You

0 Kudos
Message 674 of 676
(1,414 Views)

Hello

When I try to deploy the scan engine and EtherCAT custom device 2017 version in Veristand it shows an error(Please find the attached images few times error 4 occurs and few times error 2 ). This error will occur only when  I am using cRIO 9074 because I have also tried with cRIO 9076 using this I am not finding any error like this. Can anyone tell me what is the reason for this and how can I fix this issue

 

Thank You

Download All
0 Kudos
Message 675 of 676
(1,392 Views)

Hello, I am having same issue with cRIO-9048,

Can you share your experience/steps to resolve it

 

Thank you.

Tejaskumar Patel | (CLD)
0 Kudos
Message 676 of 676
(834 Views)