NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

type conflict in deployment

We are ttrying to port a sequence from teststand-3.1 to teststand-2013. We are using old models from teststand-3.1 . Running the sequence in the teststand development environment seems to work fine.  But when starting the OI from the deployment it complains about a type conflict in SequentialModel.seq ( which is shipped in the Teststand Public directory) . I hoped that shipping the type palette directory in Teststand Public would  solve that problem , but it does not.  Now it complains about a type confict with ini files in Teststand Public.

Whats the right way to solve such a type conflict ?

0 Kudos
Message 1 of 6
(4,604 Views)

If it's working in the teststand development environment on your development system then it should also work in an OI on your development system. The problem is likely that your deployed system is different in some way from what you have on your development system. Make sure you are deploying all of the files that go along with your old process model in the corresponding <TestStandPublic>\Components directory (not just the ones you've modified, but all of the files that belong to that process model).

 

Hope this helps,

-Doug

0 Kudos
Message 2 of 6
(4,593 Views)

In the deployment utilties System Source tab. I have enabled the check box Deploy file " from TestStand User Directory".   That should include all needed files, shouldn't it ?

And it also slould include lots of files that aren't needed for the deployment like .prj, .c, .h, .cws  files which are only needed for rebuilding from source.  Or all flavors of OIs ( with source code) where you only need one ( without source code) .

 

What specifically puzzles me , that in the first try the teststand user TypesPalettes directory on the development system was empty and the deployment  complained about a type conflict with CommonResults in sequentialmodel.seq. And after filling that directory with a copy of the ini files from the development systems teststand installation directory it now complains about a conflict in one these files when deploying  ( Error message : Type 'CommonResults'  in NI_Flowcontrol.ini (  C:\Users\Public\Documents\National Instrumemts\Teststand 2013\Components\TypePalettes\Ni_Flowcontrol.ini) is different from the currently loaded Type CommonResults). So  I may have damaged the development system with modified files ( i.e NI_Flowcontrol.ini )  in the installation directory. But why does this conflict happen on the deployed system ? Shouldn't the contents of the deployed user directory overide anything what is deployed in the teststand installation directory ? 

And what's the right fix on the development system ? A repair installation ? 

0 Kudos
Message 3 of 6
(4,541 Views)

Did you customize the CommonResults type? Do you want your customized version or the default (empty) version?

 

If you want the customized version, put it in a type palette file (mytypes.ini in public folder is a good place) on your dev machine and give it a higher version number than the default version (I think the default verison is 3.something, so 4 or higher should work). Deploy your mytypes.ini file with your version of the type.

 

If you don't want the customized version, then you should try to figure out which files it's coming from. Perhaps by opening all of the sequence files you are trying to deploy on your dev system and seeing if you get the conflict. If you do, choose the already loaded one from the type pallete and resave those sequence files.

 

Hope this helps,

-Doug

0 Kudos
Message 4 of 6
(4,535 Views)

I hope I've solved it now.  I don't remember that I modified CommonResults. But its a few years ago, that I worked first on these sequences. To solve the problem I copied the files in the components directory which were installed by the deployment into the teststand directory  ( This is a "clean" version, am I right ?) back into the teststand development installation components directory. Then I got the same error as on the deployment before also on the development system and could revert the files to be deployed in the user directory  to the standart version of  CommonResults. 

0 Kudos
Message 5 of 6
(4,532 Views)

mkossmann,

 

I'm glad to hear you have things working properly again. If you do run into this issue during deployment, one thing you can try is to use the Sequence Analyzer to analyze the files you are including in your deployment. I believe this will identify type conflicts like the one you described. You might want to use the external Sequence Analyzer utility located at Start > Programs > National Instruments > TestStand > Tools. This will let you select all of the sequence files included in your deployment and you can analyze all of them at once. 

 

Let us know if you run into any more trouble with it!

0 Kudos
Message 6 of 6
(4,530 Views)