NI TestStand

Showing results for 
Search instead for 
Did you mean: 

step into step over step out disabled while running

Hello all,


Step into, Step over and Step out are getting disabled whenever I run the sequence. Also Run Button is getting disabled after the execution breaks at break point.

Its very difficult to debug the code because of these isssues.


Is that anything to do with custom process model ? I use a third party process model. But in other PCs which are also using the same process model dont have these issues.



Message 1 of 7

Hey sridar,


Does this happen with a simple sequence file? For example, if you create a new sequence file with only a Message Popup step, set a breakpoint, and then try to debug, does it work properly or do you have the debugging buttons grayed out in this case too?


This is most likely happening because your sequence has multiple threads and not all of the threads are being suspended when you hit the breakpoint. For example, if you have a LabVIEW VI executing in a different thread when the breakpoint is hit, you will not be able to debug unless the LabVIEW thread suspends. Here is a KnowledgeBase article describing this case:


It is possible that it is being caused by the process model, but I'd start by trying a very simple sequence file. If that works properly, we know it's something in your larger sequence file. If the simple file also does not allow debugging, we might look into the process model for the issue.


Let us know if you have any further questions!

Daniel E.
TestStand Staff Product Support Engineer
National Instruments
Message 2 of 7


Message 3 of 7

Hi Doug,

it seems that was a great answer 😉
now it is emtpy.


NIWeek 2017: Standardized HIL Test Automation With TestStand
NIWeek 2016: Capturing ATE Requirements With Requirements Gateway

Feedback or kudos are welcome
0 Kudos
Message 4 of 7
Hi Daniel,
Thanks for your reply, Yes there are few Labview code modules running in threads and large sequence file. I will try your suggestions and keep posted.
0 Kudos
Message 5 of 7

@j_dodek wrote:

Hi Doug,

it seems that was a great answer 😉
now it is emtpy.


I realized I was pretty much giving the same answer as Daniel, so I just removed it.

0 Kudos
Message 6 of 7

Hi Daniel,


Its now working after I made the externally suspended setting in Labview code which is being called in my sequences.

Thank you





0 Kudos
Message 7 of 7