NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

runtime error code -17600

Solved!
Go to solution

Hello,

 

I am getting an annoying runtime error when trying to run my sequence file.

 

the error is:

Failed to load VI 'T:\ATE\TS-e-Detect\e-Detect LMC2 Status.vi' in the LabVIEW runtime engine version '13.0.1f5'.

(i have also attached a picture of the full error)

 

I have never come accross this before and am at a bit of a loss as to how to fix it!

I am uing LabVIEW 2013 verssion 13.0.1f5.

 

The VIs that the sequence file calls are published as a source distribution and located on my server, from what i can see all sub VIs have been included when the sourse distribution has been built.

 

Has anyone had this problem before and able to point me in the right direction?!

 

Any help is greatly appreciated!

 

Thanks for looking!!

 

Iain 

 

0 Kudos
Message 1 of 4
(2,681 Views)

Hi,

 

Open your test sequence and try running the "Update VI Tool" from the tools menu ( ensure your test sequence and test directories are in write mode.

It may be possible that some of the depending vi is saved in a different version.If you run the above tool it will save all dependant vis in the same version.

Note for this your LV adapter should be configured for development system.

 

Hope this helps.

 

Ravi

Message 2 of 4
(2,648 Views)
Solution
Accepted by topic author Goomba79

I found out what was causing my problem.

Some of the VIs that were being published were linked to different instances of NI SPI VIs.

I deleted all references to these VIs from my project and then remade the links and remade my source distribution.

 

Took ages to work it out but I got there in the end!

0 Kudos
Message 3 of 4
(2,576 Views)

Thanks for your reply Ravi,

I gave that a go but it didn't fix my problem unfortunately, but definately handy to know that there is a way to check and correct for version incompatabilities!

 

0 Kudos
Message 4 of 4
(2,574 Views)