NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

niScope Initialize.viThe specific niScopeDAQ or niScopeDMF dll could not be loaded.

I am getting this error when I try to use both IVI-SCOPE and NI-SCOPE in TestStand.  I make sure to close each reference before I use the next, but it seems like whichever one is called first will not release its reference unless I reboot the PC.  I wrote a LabVIEW VI that initializes the scope using IVI, then closes it and opens it wth NI-SCOPE and this seems to work fine  However, when I try to execute a sequence in TestStand that should effectively do the same thing, I get the following error when calling niscope Initialize. 

 

Details: "niScope Initialize.viThe specific niScopeDAQ or niScopeDMF dll could not be loaded."

Error Code: "-1074118608; User-defined error code."

 

I need to use both because the IVI drivers do not support phase measurements.  If anyone has any suggestions to fixing this, I would really appreciate it!  I'm using LabVIEW 2013 and TestStand 2013 and my scope is an NI PXI-5112.

 

Thanks

0 Kudos
Message 1 of 9
(3,749 Views)

Not sure if this is related, but I also get this error when I try to close TestStand, so I have to kill it with Task Manager

 

Exception From HRSULT: 0xFFFFBBA4

Error Code: -17500, Operation Faild.

Source: 'NationalInstruments.TestStand.Interop.UI'

 

(see attachement)

0 Kudos
Message 2 of 9
(3,742 Views)

If I reorder the sequence so that the niScope Initialize and Close is called before the IVI step, then I get the following error when the IVI step executes:

 

Details:

An error occurred calling 'RunStep' in 'ISubstep' of 'zNI TestStand Ivi Step Types'
An error occurred while executing the step.
Unexpected Error: The IVI instrument failed to initialize for logical name 'SXI1088_SCOPE'.
Details: niScope_InitWithOptions returned an error: -1074118608 (0xbffa4030). Primary Error: (Hex 0xBFFA4030) Unknown status code
Source: TSIviStepTypes

 

Error Code:

-1074118608; User-defined error code.

0 Kudos
Message 3 of 9
(3,736 Views)

Hi dirtyray,

 

You said you’re trying to execute a sequence in TestStand that effectively does the same thing as the LabVIEW VI—are you using a TestStand step to call that same VI? How are you calling the scope and ivi function in the TestStand steps?

TestStand error -17500 is a pretty generic error code. Does it happen every single time you try to close TestStand or only after you have tried to run this sequence?

 

K Johnson

Applications Engineer

0 Kudos
Message 4 of 9
(3,689 Views)

Hi K_Joy,

 

Thanks for the reply.  The TestStand sequence uses the built-in IVI steps to interface with the scope via IVI drivers.  The NI-SCOPE version uses TestStand Action steps with LabVIEW modules that call VI's located in the C:\Program Files\National Instruments\LabVIEW 2013\instr.lib\niScope.  I uninstalled NI-SCOPE version 4.1 and reinstalled version 4.0.5, which seems to have resolved the problem. However, now when I launch the NI-SCOPE Soft Front Panel I get this error: "The Soft Front Panel could not launch because an error occured while trying to open an application reference."  I can live without the Soft Front Panel for now, but on top of that I am now getting this error when using my DAQ module (a PXI-6221 M Series DAQ) : "Driver cannot complete the route, because the only way to make the route requires a trigger bus line, and no trigger bus has been configured in MAX for this device."  I'm currently attempting a repair installation of NI-DAQmx MAX Configuration Support 9.7.5.  Right now, I'm more or less just reinstalling differenct things because I don't know what else to do, so any insight you can offer into any of these problems would be greatly appreciated!  I've included both the TestStand sequence and the LabVIEW VI that I used to test the IVI vs NI-SCOPE problem, in case you're interested.

 

Thanks

Download All
0 Kudos
Message 5 of 9
(3,684 Views)

K_Joy,

 

I found a solution to the DAQmx error.  It looks like there was a problem with the PXI Chassis configuration in MAX.  I initially suspected this after finding an article related to the error code I was getting, but there was no option in MAX to correctly identify the PXI chassis.  Turns out, a service that detects the chassis wasn't running, so the option didn't show up.  I followed the steps in the last message of this post and was able to detect the chassis and restore my MAX settings.  

 

http://forums.ni.com/t5/Measurement-Studio-for-NET/Using-a-PXI-1033-and-a-PXI4461-amp-PXI4498-togeth...

 

Thanks anyway for your help! 

0 Kudos
Message 6 of 9
(3,634 Views)

dirtyray,

 

Glad to hear it! I'm not as familiar with PXI chassis or NI SCOPE, so if you're still having a problem with the soft front panel, I would suggest posting over on one of the hardware boards: http://forums.ni.com/t5/High-Speed-Digitizers/bd-p/150

 

Best Wishes,

K Johnson

Applications Engineer

National Instruments

0 Kudos
Message 7 of 9
(3,627 Views)

The error is back!

 

Well everything was working when I last posted to the forum, but the DLL error has come back since then.  The error message is the same as before: “niScope Initialize.viThe specific niScopeDAQ or niScopeDMF dll could not be loaded.”  After digging around in MAX the other day, I found that all of the fields for the niScope Software Module (under IVI Drivers / Advanced / Instrument Driver Software / niScope) were empty.  Filling in the Module Path with ”niScope_32.dll” and the Prefix with “niScope” cleared up the error after saving the IVI configuration in MAX restarting TestStand.  However, when I started everything up today and tried to run my sequence in TestStand, the error is back even though the settings in MAX haven’t changed.  If there is in fact a problem with the niScope Software Module, then it seems odd to me that the IVISCOPE test steps would still run fine in TestStand, but not the DAQmx.  Don’t they use the same underlying configuration from the IVI configuration store?  I’m currently attempting to a repair installation of NI IVI Compliance Package 4.6, so hopefully that will fix, but if not I’m not really sure what to do next!  If anyone has any insight onthis error, I would really appreciate it the help!

 

Thanks

0 Kudos
Message 8 of 9
(3,506 Views)

Hi,

 

Are you able to run the niScope Initialize.vi in an example in LabVIEW. If not, then the problem most likely lies with you NI-SCOPE install, and I would suggest posting to the hardware forum for additional ideas. If LabVIEW calling that VI works, then it most likely has to do with how TestStand is interacting with the driver. Could you provide a brief overveiw of what your steps are doing in your sequence?

Evan See
National Instruments
0 Kudos
Message 9 of 9
(3,475 Views)