NI TestStand

Showing results for 
Search instead for 
Did you mean: 

error 17600: How to update a prototype of a custom step type in TS3.5



I get this error:


17600; Failed to load a required step's associated module


with the details:


Error executing substep 'Post'.

The prototype of VI 'C:\... ... \SetAndCheck.llb\' changed.

The prototype needs to be updated before executing the VI. To update the prototype, open the Specify Module dialog.


Now, there is no such Specify Module dialog since the VI in the LLB is custom made (by someone else some time).


What is this all about?


I have to use TestStand 3.5 and LabVIEW 8.2.


(Someone around think she once deleted everything TestStand/LabVIEW and reinstalled everything to solve the problem.)



Joshua N

0 Kudos
Message 1 of 9


Not sure if I understand the complete question but if you right click on the step there should be "Specify Module"

Do you see that?


Can you post some image or VI that is giving the issue?

0 Kudos
Message 2 of 9



If TS ask me to update the prototype of a step, I normally just pick Specify Module from the context menu and click OK.

However, on a custom step you can disable the specify module dialog (see picture), so when TS ask you to update the prototype there is no simple clicking possibility left.


Disabled Specify Module.png


I did not create this step myself, I'm not sure how to do such things in TS. But I guess that you can somehow enable the Specify Module Dialog and thus update the prototype. That's why I ask the forum.




0 Kudos
Message 3 of 9

You can enable "Specify Module" by doing the following



1. Goto type palette, select the step type and click properties


2. Goto Disable properties and uncheck "Specify Module"


Message 4 of 9

Thanks a lot for the tip, Ranjith ,that was really a great list of settings. As for my custom step type only 'Advanced Button' is enabled in the list, i.e. 'Specify Module' and 'Edit Module Prototype' are not blocked for editing.

So I still can't update the prototype of these custom steps...




0 Kudos
Message 5 of 9

You can try the property "CanSpecifyModule" value also. If that value is false then also you cannot edit the module.


For checking the property, insert the step, right click and select "step settings", select "property browser" and check the value of property "TS.CanSpecifyModule" . It is is true, you may edit the module.



0 Kudos
Message 6 of 9

Thanks for the clue RaNad!


The manual says that CanSpecifyModule Property is a Read Only value, and I believe that's a feature of TS 4, I'm bound to use TS 3.5, I wish I were not! Seems like (again only in TS 4) using SpecMod_ReadOnly as a parameter to SpecifyModuleOptions creates a read-only version of the Specify Module dialog box.

So how about TS 3, how to update a prototype of a custom step type with disabled Specify Module?

0 Kudos
Message 7 of 9

Even if you are using TS 3.5, you can make the canSpecifyModule property editable. May be the custom step type would have defined this property as shared. FOr removing this shared behavior please do the following.


1. Select configure menu, Select Station Options-preferences-Check Show hidden properties

2. Goto type palette editor. Open the custom step type

3. Select the TS.canSpecifyModule property, ensure its true.

4. Else , Select properties , click advanced and edit flags

5. Un check the propflags_Shared

6. Change TS.canSpecifyModule property to true.


Hope this  helps.



0 Kudos
Message 8 of 9

Well, on my custom step types the TS.canSpecifyModule property is already true and the propflags_Shared is also unchecked...



0 Kudos
Message 9 of 9